Injection in Apache DeltaSpike
Priority LOW 32CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
we got reports for 2 injection attacks against the DeltaSpike windowhandler.js. This is only active if a developer selected the ClientSideWindowStrategy which is not the default.
Why it matters now
EPSS 0.02714 86th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed org.apache.deltaspike:deltaspike (Maven): 1.9.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Apache DeltaSpike | Apache DeltaSpike up to including 1.9.2 | — | No fix listed | CNA |
| — | org.apache.deltaspike:deltaspike (Maven) | before 1.9.4 | 1.9.4 | Patch available | GHSA-rhg5-fqr3-hrf5 |
- Apache DeltaSpike Vendor— Affected Apache DeltaSpike up to including 1.9.2 Fixed in — No fix listed CNA
- org.apache.deltaspike:deltaspike (Maven) Vendor— Affected before 1.9.4 Fixed in 1.9.4 Patch available GHSA-rhg5-fqr3-hrf5
Remediation
- Fix · GHSA-rhg5-fqr3-hrf5 org.apache.deltaspike:deltaspike (Maven) Fixed in 1.9.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-12416
- 2026-10-03 Alias added: GHSA-rhg5-fqr3-hrf5
References
More Apache Deltaspike vulnerabilities
- TI-2017-13073 Cross-site scripting in Apache DeltaSpike CVSS 3.1MEDIUM 6.1
Sources
- CVE-2019-12416 · CVE Program
- CVE-2019-12416 · NVD
- FIRST EPSS
- GHSA-rhg5-fqr3-hrf5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences