Read the docs
TI-2019-09309 Aliases CVE-2019-12468GHSA-wrhx-3pxr-6vgg

An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.27.0 through…

Priority MEDIUM 48CWE-306Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-306.

Summary

An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.27.0 through 1.32.1. Directly POSTing to Special:ChangeEmail would allow for bypassing re-authentication, allowing for potential account takeover.

Why it matters now

EPSS 0.03334 88th percentileScored 2026-11-07
Fix Fixed mediawiki/core (Packagist): 1.27.6, 1.30.2, 1.31.2 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mediawiki/core (Packagist)1.27.0 to before 1.27.61.27.6Patch availableGHSA-wrhx-3pxr-6vgg
—mediawiki/core (Packagist)1.30.0 to before 1.30.21.30.2Patch availableGHSA-wrhx-3pxr-6vgg
—mediawiki/core (Packagist)1.31.0 to before 1.31.21.31.2Patch availableGHSA-wrhx-3pxr-6vgg
—mediawiki/core (Packagist)1.32.0 to before 1.32.21.32.2Patch availableGHSA-wrhx-3pxr-6vgg
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mediawiki/core (Packagist) Vendor— Affected 1.27.0 to before 1.27.6 Fixed in 1.27.6 Patch available GHSA-wrhx-3pxr-6vgg
  • mediawiki/core (Packagist) Vendor— Affected 1.30.0 to before 1.30.2 Fixed in 1.30.2 Patch available GHSA-wrhx-3pxr-6vgg
  • mediawiki/core (Packagist) Vendor— Affected 1.31.0 to before 1.31.2 Fixed in 1.31.2 Patch available GHSA-wrhx-3pxr-6vgg
  • mediawiki/core (Packagist) Vendor— Affected 1.32.0 to before 1.32.2 Fixed in 1.32.2 Patch available GHSA-wrhx-3pxr-6vgg

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:*1.27.0 – 1.32.1Vulnerablemediawiki
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions 1.27.0 – 1.32.1 Vulnerable ·mediawiki
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-wrhx-3pxr-6vgg mediawiki/core (Packagist) Fixed in 1.27.6 Advisory →
  • Fix · GHSA-wrhx-3pxr-6vgg mediawiki/core (Packagist) Fixed in 1.30.2 Advisory →
  • Fix · GHSA-wrhx-3pxr-6vgg mediawiki/core (Packagist) Fixed in 1.31.2 Advisory →
  • Fix · GHSA-wrhx-3pxr-6vgg mediawiki/core (Packagist) Fixed in 1.32.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-12468
  2. 2026-10-03 Alias added: GHSA-wrhx-3pxr-6vgg

References

Sources