Read the docs
TI-2019-09312 Aliases CVE-2019-12471GHSA-2rm7-xxx8-35jh

Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS.

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

Why it matters now

EPSS 0.01285 70th percentileScored 2026-11-07
Fix Fixed mediawiki/core (Packagist): 1.27.6, 1.30.2, 1.31.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mediawiki/core (Packagist)1.27.0 to before 1.27.61.27.6Patch availableGHSA-2rm7-xxx8-35jh
—mediawiki/core (Packagist)1.30.0 to before 1.30.21.30.2Patch availableGHSA-2rm7-xxx8-35jh
—mediawiki/core (Packagist)1.31.0 to before 1.31.21.31.2Patch availableGHSA-2rm7-xxx8-35jh
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mediawiki/core (Packagist) Vendor— Affected 1.27.0 to before 1.27.6 Fixed in 1.27.6 Patch available GHSA-2rm7-xxx8-35jh
  • mediawiki/core (Packagist) Vendor— Affected 1.30.0 to before 1.30.2 Fixed in 1.30.2 Patch available GHSA-2rm7-xxx8-35jh
  • mediawiki/core (Packagist) Vendor— Affected 1.31.0 to before 1.31.2 Fixed in 1.31.2 Patch available GHSA-2rm7-xxx8-35jh

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:*1.30.0 to before 1.30.2; 1.31.0 to before 1.31.2; 1.32.0 to before 1.32.2Vulnerablemediawiki
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions 1.30.0 to before 1.30.2; 1.31.0 to before 1.31.2; 1.32.0 to before 1.32.2 Vulnerable ·mediawiki
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-2rm7-xxx8-35jh mediawiki/core (Packagist) Fixed in 1.27.6 Advisory →
  • Fix · GHSA-2rm7-xxx8-35jh mediawiki/core (Packagist) Fixed in 1.30.2 Advisory →
  • Fix · GHSA-2rm7-xxx8-35jh mediawiki/core (Packagist) Fixed in 1.31.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-12471
  2. 2026-10-03 Alias added: GHSA-2rm7-xxx8-35jh

References

Sources