An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through…
Priority LOW 36CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Why it matters now
EPSS 0.01325 71st percentileScored 2026-11-07
Fix Fixed mediawiki/core (Packagist): 1.27.6, 1.30.2, 1.31.2 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mediawiki/core (Packagist) | 1.18.0 to before 1.27.6 | 1.27.6 | Patch available | GHSA-7mqg-5fgh-xh4r |
| — | mediawiki/core (Packagist) | 1.30.0 to before 1.30.2 | 1.30.2 | Patch available | GHSA-7mqg-5fgh-xh4r |
| — | mediawiki/core (Packagist) | 1.31.0 to before 1.31.2 | 1.31.2 | Patch available | GHSA-7mqg-5fgh-xh4r |
| — | mediawiki/core (Packagist) | 1.32.0 to before 1.32.2 | 1.32.2 | Patch available | GHSA-7mqg-5fgh-xh4r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mediawiki/core (Packagist) Vendor— Affected 1.18.0 to before 1.27.6 Fixed in 1.27.6 Patch available GHSA-7mqg-5fgh-xh4r
- mediawiki/core (Packagist) Vendor— Affected 1.30.0 to before 1.30.2 Fixed in 1.30.2 Patch available GHSA-7mqg-5fgh-xh4r
- mediawiki/core (Packagist) Vendor— Affected 1.31.0 to before 1.31.2 Fixed in 1.31.2 Patch available GHSA-7mqg-5fgh-xh4r
- mediawiki/core (Packagist) Vendor— Affected 1.32.0 to before 1.32.2 Fixed in 1.32.2 Patch available GHSA-7mqg-5fgh-xh4r
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* | 1.18.0 to before 1.27.6; 1.30.0 to before 1.30.2; 1.31.0 to before 1.31.2; 1.32.0 to before 1.32.2 | Vulnerable | mediawiki |
- cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions 1.18.0 to before 1.27.6; 1.30.0 to before 1.30.2; 1.31.0 to before 1.31.2; 1.32.0 to before 1.32.2 Vulnerable ·mediawiki
Remediation
- Fix · GHSA-7mqg-5fgh-xh4r mediawiki/core (Packagist) Fixed in 1.27.6 Advisory →
- Fix · GHSA-7mqg-5fgh-xh4r mediawiki/core (Packagist) Fixed in 1.30.2 Advisory →
- Fix · GHSA-7mqg-5fgh-xh4r mediawiki/core (Packagist) Fixed in 1.31.2 Advisory →
- Fix · GHSA-7mqg-5fgh-xh4r mediawiki/core (Packagist) Fixed in 1.32.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-12472
- 2026-10-03 Alias added: GHSA-7mqg-5fgh-xh4r
References
More Mediawiki vulnerabilities
- TI-2023-18933 An issue was discovered in the CheckUser extension for MediaWiki through 1.39.3. CVSS 3.1CRITICAL 9.8
- TI-2023-13576 An issue was discovered in MediaWiki before 1.35.10, 1.36.x through 1.38.x before 1.38.6… CVSS 3.1CRITICAL 9.8
- TI-2023-03312 Stored XSS leads to privilege escalation in MediaWiki v1.40.0 CVSS 3.1CRITICAL 9.0
- TI-2026-42109 Cross-site request forgery in Wikimedia Foundation Mediawiki - RedirectManager Extension CVSS 4.0MEDIUM 6.9
- TI-2024-22822 An issue was discovered in includes/CommentFormatter/CommentParser.php in MediaWiki… CVSS 3.1HIGH 7.4
- TI-2023-18935 An issue was discovered in the ProofreadPage (aka Proofread Page) extension for MediaWiki… CVSS 3.1MEDIUM 5.3
Sources
- CVE-2019-12472 · CVE Program
- CVE-2019-12472 · NVD
- FIRST EPSS
- GHSA-7mqg-5fgh-xh4r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences