Read the docs
TI-2019-09315 Aliases CVE-2019-12474GHSA-2qrr-c2gh-pr35

Wikimedia MediaWiki 1.23.0 through 1.32.1 has an information leak.

Priority LOW 37CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

Wikimedia MediaWiki 1.23.0 through 1.32.1 has an information leak. Privileged API responses that include whether a recent change has been patrolled may be cached publicly. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

Why it matters now

EPSS 0.02043 81st percentileScored 2026-11-07
Fix Fixed mediawiki/core (Packagist): 1.27.6, 1.30.2, 1.31.2 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mediawiki/core (Packagist)1.27.0 to before 1.27.61.27.6Patch availableGHSA-2qrr-c2gh-pr35
—mediawiki/core (Packagist)1.30.0 to before 1.30.21.30.2Patch availableGHSA-2qrr-c2gh-pr35
—mediawiki/core (Packagist)1.31.0 to before 1.31.21.31.2Patch availableGHSA-2qrr-c2gh-pr35
—mediawiki/core (Packagist)1.32.0 to before 1.32.21.32.2Patch availableGHSA-2qrr-c2gh-pr35
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mediawiki/core (Packagist) Vendor— Affected 1.27.0 to before 1.27.6 Fixed in 1.27.6 Patch available GHSA-2qrr-c2gh-pr35
  • mediawiki/core (Packagist) Vendor— Affected 1.30.0 to before 1.30.2 Fixed in 1.30.2 Patch available GHSA-2qrr-c2gh-pr35
  • mediawiki/core (Packagist) Vendor— Affected 1.31.0 to before 1.31.2 Fixed in 1.31.2 Patch available GHSA-2qrr-c2gh-pr35
  • mediawiki/core (Packagist) Vendor— Affected 1.32.0 to before 1.32.2 Fixed in 1.32.2 Patch available GHSA-2qrr-c2gh-pr35

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:*1.23.0 to before 1.27.6; 1.30.0 to before 1.30.2; 1.31.0 to before 1.31.2; 1.32.0 to before 1.32.2Vulnerablemediawiki
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions 1.23.0 to before 1.27.6; 1.30.0 to before 1.30.2; 1.31.0 to before 1.31.2; 1.32.0 to before 1.32.2 Vulnerable ·mediawiki
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-2qrr-c2gh-pr35 mediawiki/core (Packagist) Fixed in 1.27.6 Advisory →
  • Fix · GHSA-2qrr-c2gh-pr35 mediawiki/core (Packagist) Fixed in 1.30.2 Advisory →
  • Fix · GHSA-2qrr-c2gh-pr35 mediawiki/core (Packagist) Fixed in 1.31.2 Advisory →
  • Fix · GHSA-2qrr-c2gh-pr35 mediawiki/core (Packagist) Fixed in 1.32.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-12474
  2. 2026-10-03 Alias added: GHSA-2qrr-c2gh-pr35

References

Sources