Read the docs
TI-2019-09440 Aliases CVE-2019-12644GHSA-wqfg-hv39-hm6x

Cisco Identity Services Engine Cross-Site Scripting Vulnerability

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

A vulnerability in the web-based management interface of Cisco Identity Services Engine (ISE) Software could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the web-based management interface of an affected device. The vulnerability exists because the web-based management interface of the affected device does not properly validate user-supplied input. An attacker could exploit this vulnerability by persuading a user to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01109 66th percentileScored 2026-11-07
Fix Fixed Cisco Identity Services Engine Software (Cisco): 2.6.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
CiscoCisco Identity Services Engine Softwarebefore 2.6.02.6.0Patch availableCNA
  • Cisco Identity Services Engine Software VendorCisco Affected before 2.6.0 Fixed in 2.6.0 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:cisco:identity_services_engine:*:*:*:*:*:*:*:*before 2.6.0VulnerableCisco
cpe:2.3:a:cisco:identity_services_engine:2.7\(0.207\):*:*:*:*:*:*:*2.7(0.207)VulnerableCisco
  • cpe:2.3:a:cisco:identity_services_engine:*:*:*:*:*:*:*:* Versions before 2.6.0 Vulnerable ·Cisco
  • cpe:2.3:a:cisco:identity_services_engine:2.7\(0.207\):*:*:*:*:*:*:* Versions 2.7(0.207) Vulnerable ·Cisco

Remediation

  • Fix · CNA Cisco Identity Services Engine Software (Cisco) Fixed in 2.6.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-12644
  2. 2026-10-03 Alias added: GHSA-wqfg-hv39-hm6x

References

  • TI-2026-53488 Cisco Identity Services Engine Authentication Bypass Vulnerability KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-14632 Cisco ISE API Unauthenticated Remote Code Execution Vulnerability KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-14578 Cisco ISE API Unauthenticated Remote Code Execution Vulnerability KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-19919 Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-14579 Cisco ISE API Unauthenticated Remote Code Execution Vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2022-05522 OS command injection in Cisco Identity Services Engine Software CVSS 3.1HIGH 8.8
See all 197 →

Sources