Read the docs
TI-2019-10138 Aliases CVE-2019-13506GHSA-6677-83pp-f862

@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS.

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS.

Why it matters now

EPSS 0.01347 71st percentileScored 2026-11-07
Fix Fixed @nuxt/devalue (npm): 1.2.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—@nuxt/devalue (npm)before 1.2.31.2.3Patch availableGHSA-6677-83pp-f862
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • @nuxt/devalue (npm) Vendor— Affected before 1.2.3 Fixed in 1.2.3 Patch available GHSA-6677-83pp-f862

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:nuxtjs:\@nuxt\/devalue:*:*:*:*:*:node.js:*:*before 1.2.3VulnerableNuxtjs
cpe:2.3:a:nuxtjs:nuxt.js:*:*:*:*:*:node.js:*:*before 2.6.2VulnerableNuxtjs
  • cpe:2.3:a:nuxtjs:\@nuxt\/devalue:*:*:*:*:*:node.js:*:* Versions before 1.2.3 Vulnerable ·Nuxtjs
  • cpe:2.3:a:nuxtjs:nuxt.js:*:*:*:*:*:node.js:*:* Versions before 2.6.2 Vulnerable ·Nuxtjs

Remediation

  • Fix · GHSA-6677-83pp-f862 @nuxt/devalue (npm) Fixed in 1.2.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-13506
  2. 2026-10-03 Alias added: GHSA-6677-83pp-f862

References

Sources