Path traversal in CODESYS V3 web server
Priority LOW 39CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.
Summary
CODESYS V3 web server, all versions prior to 3.5.14.10, allows an attacker to send specially crafted http or https requests which may allow access to files outside the restricted working directory of the controller.
Why it matters now
EPSS 0.03473 89th percentileScored 2026-11-07
Fix Fixed CODESYS V3 web server: 3.5.14.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | CODESYS V3 web server | before 3.5.14.10 | 3.5.14.10 | Patch available | CNA |
- CODESYS V3 web server Vendor— Affected before 3.5.14.10 Fixed in 3.5.14.10 Patch available CNA
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:codesys:control_for_beaglebone:*:*:*:*:*:*:*:* | before 3.5.14.10 | Vulnerable | CODESYS |
| cpe:2.3:a:codesys:control_for_empc-a\/imx6:*:*:*:*:*:*:*:* | before 3.5.14.10 | Vulnerable | CODESYS |
| cpe:2.3:a:codesys:control_for_iot2000:*:*:*:*:*:*:*:* | before 3.5.14.10 | Vulnerable | CODESYS |
| cpe:2.3:a:codesys:control_for_linux:*:*:*:*:*:*:*:* | before 3.5.14.10 | Vulnerable | CODESYS |
| cpe:2.3:a:codesys:control_for_pfc100:*:*:*:*:*:*:*:* | before 3.5.14.10 | Vulnerable | CODESYS |
| cpe:2.3:a:codesys:control_for_pfc200:*:*:*:*:*:*:*:* | before 3.5.14.10 | Vulnerable | CODESYS |
| cpe:2.3:a:codesys:control_for_raspberry_pi:*:*:*:*:*:*:*:* | before 3.5.14.10 | Vulnerable | CODESYS |
| cpe:2.3:a:codesys:control_rte:*:*:*:*:*:*:*:* | 3.5.8.60 to before 3.5.12.80; 3.5.13.0 to before 3.5.14.10 | Vulnerable | CODESYS |
| cpe:2.3:a:codesys:control_runtime_system_toolkit:*:*:*:*:*:*:*:* | 3.0 to before 3.5.12.80 | Vulnerable | CODESYS |
| cpe:2.3:a:codesys:control_win:*:*:*:*:*:*:*:* | 3.5.9.80 – 3.5.12.80; 3.5.13.0 to before 3.5.14.10 | Vulnerable | CODESYS |
- cpe:2.3:a:codesys:control_for_beaglebone:*:*:*:*:*:*:*:* Versions before 3.5.14.10 Vulnerable ·CODESYS
- cpe:2.3:a:codesys:control_for_empc-a\/imx6:*:*:*:*:*:*:*:* Versions before 3.5.14.10 Vulnerable ·CODESYS
- cpe:2.3:a:codesys:control_for_iot2000:*:*:*:*:*:*:*:* Versions before 3.5.14.10 Vulnerable ·CODESYS
- cpe:2.3:a:codesys:control_for_linux:*:*:*:*:*:*:*:* Versions before 3.5.14.10 Vulnerable ·CODESYS
- cpe:2.3:a:codesys:control_for_pfc100:*:*:*:*:*:*:*:* Versions before 3.5.14.10 Vulnerable ·CODESYS
- cpe:2.3:a:codesys:control_for_pfc200:*:*:*:*:*:*:*:* Versions before 3.5.14.10 Vulnerable ·CODESYS
- cpe:2.3:a:codesys:control_for_raspberry_pi:*:*:*:*:*:*:*:* Versions before 3.5.14.10 Vulnerable ·CODESYS
- cpe:2.3:a:codesys:control_rte:*:*:*:*:*:*:*:* Versions 3.5.8.60 to before 3.5.12.80; 3.5.13.0 to before 3.5.14.10 Vulnerable ·CODESYS
- cpe:2.3:a:codesys:control_runtime_system_toolkit:*:*:*:*:*:*:*:* Versions 3.0 to before 3.5.12.80 Vulnerable ·CODESYS
- cpe:2.3:a:codesys:control_win:*:*:*:*:*:*:*:* Versions 3.5.9.80 – 3.5.12.80; 3.5.13.0 to before 3.5.14.10 Vulnerable ·CODESYS
Show 3 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:codesys:embedded_target_visu_toolkit:*:*:*:*:*:*:*:* | 3.0 to before 3.5.12.80 | Vulnerable | CODESYS |
| cpe:2.3:a:codesys:hmi:*:*:*:*:*:*:*:* | 3.5.10.0 to before 3.5.12.80; 3.5.13.0 to before 3.5.14.10 | Vulnerable | CODESYS |
| cpe:2.3:a:codesys:remote_target_visu_toolkit:*:*:*:*:*:*:*:* | 3.0 to before 3.5.12.80 | Vulnerable | CODESYS |
- cpe:2.3:a:codesys:embedded_target_visu_toolkit:*:*:*:*:*:*:*:* Versions 3.0 to before 3.5.12.80 Vulnerable ·CODESYS
- cpe:2.3:a:codesys:hmi:*:*:*:*:*:*:*:* Versions 3.5.10.0 to before 3.5.12.80; 3.5.13.0 to before 3.5.14.10 Vulnerable ·CODESYS
- cpe:2.3:a:codesys:remote_target_visu_toolkit:*:*:*:*:*:*:*:* Versions 3.0 to before 3.5.12.80 Vulnerable ·CODESYS
Remediation
- Fix · CNA CODESYS V3 web server Fixed in 3.5.14.10
Timeline
- 2026-10-02 Threatist record created from CVE-2019-13532
- 2026-10-03 Alias added: GHSA-f2j7-4v6c-qhf6
References
More CODESYS Control For Beaglebone vulnerabilities
- TI-2019-10180 Stack-based buffer overflow in CODESYS V3 web server CVSS 3.1CRITICAL 9.8
- TI-2020-08257 CODESYS V3 web server before 3.5.15.40, as used in CODESYS Control runtime systems, has a buffer overflow. CVSS 3.1CRITICAL 9.8
- TI-2019-13592 CODESYS 3 web server before 3.5.15.20, as distributed with CODESYS Control runtime systems, has a Buffer Overflow. CVSS 3.1CRITICAL 9.8
- TI-2019-06495 An issue was discovered in 3S-Smart CODESYS V3 through 3.5.12.30. CVSS 3.1HIGH 8.8
- TI-2018-15275 Codesys Runtime Improper Limitation of a Pathname CVSS 3.1HIGH 8.8
- TI-2020-12439 CODESYS Control runtime system before 3.5.16.10 allows Uncontrolled Memory Allocation. CVSS 3.1HIGH 7.5
Sources
- CVE-2019-13532 · CVE Program
- CVE-2019-13532 · NVD
- FIRST EPSS
- GHSA-f2j7-4v6c-qhf6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences