In lib/mini_magick/image.rb in MiniMagick before 4.9.4, a fetched remote image filename…
Priority MEDIUM 44CWE-78Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
In lib/mini_magick/image.rb in MiniMagick before 4.9.4, a fetched remote image filename could cause remote command execution because Image.open input is directly passed to Kernel#open, which accepts a '|' character followed by a command.
Why it matters now
EPSS 0.07639 94th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed mini_magick (RubyGems): 4.9.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mini_magick (RubyGems) | before 4.9.4 | 4.9.4 | Patch available | GHSA-r7j3-vvh2-xrpj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mini_magick (RubyGems) Vendor— Affected before 4.9.4 Fixed in 4.9.4 Patch available GHSA-r7j3-vvh2-xrpj
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:minimagick_project:minimagick:*:*:*:*:*:*:*:* | before 4.9.4 | Vulnerable | Minimagick Project |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:minimagick_project:minimagick:*:*:*:*:*:*:*:* Versions before 4.9.4 Vulnerable ·Minimagick Project
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-r7j3-vvh2-xrpj mini_magick (RubyGems) Fixed in 4.9.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-13574
- 2026-10-03 Alias added: GHSA-r7j3-vvh2-xrpj
References
Patch 2
Advisory 4
Other 4
- [debian-lts-announce] 20191007 [SECURITY] [DLA 1948-1] ruby-mini-magick security update
- https://benjamin-bouchet.com/blog/vulnerabilite-dans-la-gem-mini_magick-version-4-9-4
- https://github.com/minimagick/minimagick
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/mini_magick/CVE-2019-13574.yml
Sources
- CVE-2019-13574 · CVE Program
- CVE-2019-13574 · NVD
- FIRST EPSS
- GHSA-r7j3-vvh2-xrpj · GitHub Advisory Database · CC BY 4.0
- CVE-2019-13574 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences