Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some…
Priority MEDIUM 53CWE-19Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $local_part or $domain).
Why it matters now
EPSS 0.08622 95th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Enterprise Linux 5
Timeline
- 2026-10-02 Threatist record created from CVE-2019-13917
- 2026-10-03 Alias added: GHSA-w2fj-xv79-84gh
- 2026-10-13 EPSS moved to the 95th–99th percentile
References
Sources
- CVE-2019-13917 · CVE Program
- CVE-2019-13917 · NVD
- FIRST EPSS
- GHSA-w2fj-xv79-84gh · GitHub Advisory Database · CC BY 4.0
- CVE-2019-13917 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences