In antSword before 2.1.0, self-XSS in the database configuration leads to code execution…
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In antSword before 2.1.0, self-XSS in the database configuration leads to code execution via modules/database/asp/index.js, modules/database/custom/index.js, modules/database/index.js, or modules/database/php/index.js.
Why it matters now
EPSS 0.01874 79th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed antsword (npm): 2.1.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | antsword (npm) | before 2.1.0 | 2.1.0 | Patch available | GHSA-hq75-ggc3-8h3q |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- antsword (npm) Vendor— Affected before 2.1.0 Fixed in 2.1.0 Patch available GHSA-hq75-ggc3-8h3q
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:antsword_project:antsword:*:*:*:*:*:*:*:* | before 2.1.0 | Vulnerable | AntSwordProject |
- cpe:2.3:a:antsword_project:antsword:*:*:*:*:*:*:*:* Versions before 2.1.0 Vulnerable ·AntSwordProject
Remediation
- Fix · GHSA-hq75-ggc3-8h3q antsword (npm) Fixed in 2.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-13970
- 2026-10-03 Alias added: GHSA-hq75-ggc3-8h3q
References
Advisory 2
More AntSwordProject Antsword vulnerabilities
- TI-2020-13467 A cross-site scripting (XSS) vulnerability AntSword v2.0.7 can remotely execute system commands. CVSS 3.1CRITICAL 9.6
- TI-2020-15566 AntSword 2.1.8.1 contains a cross-site scripting (XSS) vulnerability in the View Site… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2019-13970 · CVE Program
- CVE-2019-13970 · NVD
- FIRST EPSS
- GHSA-hq75-ggc3-8h3q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences