In Docker 19.03.x before 19.03.1 linked against the GNU C Library (aka glibc), code…
Priority MEDIUM 60CWE-665Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
In Docker 19.03.x before 19.03.1 linked against the GNU C Library (aka glibc), code injection can occur when the nsswitch facility dynamically loads a library inside a chroot that contains the contents of the container.
Why it matters now
EPSS 0.18828 97th percentileScored 2026-11-07
Fix Fixed github.com/docker/docker (Go): 19.03.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/docker/docker (Go) | 19.03.0 to before 19.03.1 | 19.03.1 | Patch available | GHSA-v2cv-wwxq-qq97 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/docker/docker (Go) Vendor— Affected 19.03.0 to before 19.03.1 Fixed in 19.03.1 Patch available GHSA-v2cv-wwxq-qq97
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:docker:docker:*:*:*:*:*:*:*:* | 19.03 to before 19.03.1 | Vulnerable | Docker |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:* | 15.0 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
- cpe:2.3:a:docker:docker:*:*:*:*:*:*:*:* Versions 19.03 to before 19.03.1 Vulnerable ·Docker
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:* Versions 15.0 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
Remediation
- Fix · GHSA-v2cv-wwxq-qq97 github.com/docker/docker (Go) Fixed in 19.03.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Enterprise Linux 7
- Red Hat Storage 3
Timeline
- 2026-10-02 Threatist record created from CVE-2019-14271
- 2026-10-03 Alias added: GHSA-v2cv-wwxq-qq97
References
Advisory 7
Other 6
- https://github.com/moby/moby/pull/39612
- https://github.com/moby/moby/commit/11e48badcb67554b3d795241855028f28d244545
- https://github.com/moby/moby/commit/fa8dd90ceb7bcb9d554d27e0b9087ab83e54bd2b
- https://docs.docker.com/engine/release-notes
- https://github.com/moby/moby
- https://security.netapp.com/advisory/ntap-20190828-0003
Sources
- CVE-2019-14271 · CVE Program
- CVE-2019-14271 · NVD
- FIRST EPSS
- GHSA-v2cv-wwxq-qq97 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-14271 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences