Incorrect permission assignment in Red Hat ghostscript
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 11 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
A flaw was found in all ghostscript versions 9.x before 9.50, in the .setuserparams2 procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | ghostscript | 9 to before 9.50 | 9.50 | Patch available | CNA |
- ghostscript VendorRed Hat Affected 9 to before 9.50 Fixed in 9.50 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:* | 9.00 to before 9.50 | Vulnerable | Artifex |
| cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* | 31 | Vulnerable | Fedoraproject |
- cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:* Versions 9.00 to before 9.50 Vulnerable ·Artifex
- cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
Remediation
Red Hat 3 advisories
- RHSA-2019:2586 Released 2019-09-02 · Red Hat rating Importantghostscript security update
- Red Hat Enterprise Linux Client (v. 7) ghostscript-9.25-2.el7_7.2, ghostscript-cups-9.25-2.el7_7.2, libgs-9.25-2.el7_7.2
- Red Hat Enterprise Linux Client Optional (v. 7) ghostscript-doc-9.25-2.el7_7.2, ghostscript-gtk-9.25-2.el7_7.2, libgs-devel-9.25-2.el7_7.2
- Red Hat Enterprise Linux ComputeNode (v. 7) ghostscript-9.25-2.el7_7.2, ghostscript-cups-9.25-2.el7_7.2, libgs-9.25-2.el7_7.2
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) ghostscript-doc-9.25-2.el7_7.2, ghostscript-gtk-9.25-2.el7_7.2, libgs-devel-9.25-2.el7_7.2
- Red Hat Enterprise Linux Server (v. 7) ghostscript-9.25-2.el7_7.2, ghostscript-9.25-2.el7_7.2.ppc, ghostscript-cups-9.25-2.el7_7.2 +2
- Red Hat Enterprise Linux Server Optional (v. 7) ghostscript-doc-9.25-2.el7_7.2, ghostscript-gtk-9.25-2.el7_7.2, libgs-devel-9.25-2.el7_7.2 +1
- Red Hat Enterprise Linux Workstation (v. 7) ghostscript-9.25-2.el7_7.2, ghostscript-cups-9.25-2.el7_7.2, libgs-9.25-2.el7_7.2
- Red Hat Enterprise Linux Workstation Optional (v. 7) ghostscript-doc-9.25-2.el7_7.2, ghostscript-gtk-9.25-2.el7_7.2, libgs-devel-9.25-2.el7_7.2
- RHSA-2019:2591 Released 2019-09-02 · Red Hat rating Importantghostscript security update
- Red Hat CodeReady Linux Builder (v. 8) ghostscript-doc-9.25-2.el8_0.3, ghostscript-tools-dvipdf-9.25-2.el8_0.3, ghostscript-tools-fonts-9.25-2.el8_0.3 +3
- Red Hat Enterprise Linux AppStream (v. 8) ghostscript-9.25-2.el8_0.3, libgs-9.25-2.el8_0.3
- RHSA-2019:2534 Released 2019-08-21 · Red Hat rating ImportantRed Hat 3scale API Management 2.6.0 release and security update
- RHAMP-2.6 3scale-amp26/3scale-operator, 3scale-amp26/apicast-gateway, 3scale-amp26/backend +3
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| RHAMP-2.6 | Fixed | RHSA-2019:2534 |
| Red Hat CodeReady Linux Builder (v. 8) | Fixed | RHSA-2019:2591 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2019:2591 |
| Red Hat Enterprise Linux Client (v. 7) | Fixed | RHSA-2019:2586 |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2019:2586 |
| Red Hat Enterprise Linux ComputeNode (v. 7) | Fixed | RHSA-2019:2586 |
| Red Hat Enterprise Linux ComputeNode Optional (v. 7) | Fixed | RHSA-2019:2586 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2019:2586 |
| Red Hat Enterprise Linux Server Optional (v. 7) | Fixed | RHSA-2019:2586 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2019:2586 |
| Red Hat Enterprise Linux Workstation Optional (v. 7) | Fixed | RHSA-2019:2586 |
Not affected: 1 product
- Red Hat 3scale API Management Platform 2
Timeline
- 2026-10-02 Threatist record created from CVE-2019-14812
- 2026-10-03 Alias added: GHSA-rmmv-j9x6-f2v4
References
Advisory 3
More Red Hat vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-14812 · CVE Program
- CVE-2019-14812 · NVD
- FIRST EPSS
- GHSA-rmmv-j9x6-f2v4 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-14812 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences