Bagisto 0.1.5 allows CSRF under /admin URIs.
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Bagisto 0.1.5 allows CSRF under /admin URIs.
Why it matters now
EPSS 0.00603 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed bagisto/bagisto (Packagist): 0.1.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | bagisto/bagisto (Packagist) | before 0.1.5 | 0.1.5 | Patch available | GHSA-pgwp-f3xh-m24g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- bagisto/bagisto (Packagist) Vendor— Affected before 0.1.5 Fixed in 0.1.5 Patch available GHSA-pgwp-f3xh-m24g
Remediation
- Fix · GHSA-pgwp-f3xh-m24g bagisto/bagisto (Packagist) Fixed in 0.1.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-14933
- 2026-10-03 Alias added: GHSA-pgwp-f3xh-m24g
References
More Webkul Bagisto vulnerabilities
- TI-2026-17332 Bagisto has Normal & Blind SSTI from low-privilege user when ordering product CVSS 4.0HIGH 8.9
- TI-2023-16589 Bagisto v1.5.1 is vulnerable to Server-Side Template Injection (SSTI). CVSS 3.1HIGH 8.8
- TI-2026-17331 Bagisto has IDOR in Customer Order Reorder Functionality CVSS 3.1HIGH 7.1
- TI-2025-37847 An authenticated stored XSS vulnerability exists in the Bagisto 2.3.6 admin panel's… CVSS 3.1HIGH 8.3
- TI-2026-17333 Bagisto has SSTI via first and last name from low-privilege user (not admin) CVSS 4.0HIGH 7.4
- TI-2025-38684 bagisto - CSV Formula Injection in Create New Product CVSS 4.0HIGH 7.1
Sources
- CVE-2019-14933 · CVE Program
- CVE-2019-14933 · NVD
- FIRST EPSS
- GHSA-pgwp-f3xh-m24g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences