An issue was discovered in Webmin <=1.920.
Priority CRITICAL 100Exploited in the wildCWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-78.
Summary
An issue was discovered in Webmin <=1.920. The parameter old in password_change.cgi contains a command injection vulnerability.
Why it matters now
Exploitation Active In CISA KEV since 2022-03-25CISA due date 2022-04-15Known ransomware use
EPSS 0.9971 99th percentileScored 2026-11-07
Public exploit Yes 5 exploit referencesTagged by NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2022-03-25 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2019-15107
- 2026-10-03 Alias added: GHSA-69hp-hrv4-rxrr
References
Exploit 5
- https://www.exploit-db.com/exploits/47230
- http://www.pentest.com.tr/exploits/DEFCON-Webmin-1920-Unauthenticated-Remote-Command-Execution.html
- http://packetstormsecurity.com/files/154141/Webmin-Remote-Comman-Execution.html
- http://packetstormsecurity.com/files/154141/Webmin-1.920-Remote-Command-Execution.html
- http://packetstormsecurity.com/files/154197/Webmin-1.920-password_change.cgi-Backdoor.html
More Webmin vulnerabilities
- TI-2022-16770 software/apt-lib.pl in Webmin before 1.997 lacks HTML escaping for a UI command. CVSS 3.1CRITICAL 9.8
- TI-2022-00731 Improper Access Control to Remote Code Execution in webmin/webmin CVSS 3.1HIGH 8.8
- TI-2019-09619 In Webmin through 1.910, any user authorized to the "Package Updates" module can execute… CVSS 3.0HIGH 8.8
- TI-2021-11777 Webmin 1.973 is affected by reflected Cross Site Scripting (XSS) to achieve Remote… CVSS 3.1CRITICAL 9.6
- TI-2024-11888 OS command injection in Webmin CVSS 3.1HIGH 8.8
- TI-2020-07078 An Improper Data Validation Vulnerability exists in Webmin 1.941 and earlier affecting… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2019-15107 · CVE Program
- CVE-2019-15107 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-69hp-hrv4-rxrr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences