lib/install/install.go in cnlh nps through 0.23.2 uses 0777 permissions for…
Priority LOW 27CWE-732Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
lib/install/install.go in cnlh nps through 0.23.2 uses 0777 permissions for /usr/local/bin/nps and/or /usr/bin/nps, leading to a file overwrite by a local user.
Why it matters now
EPSS 0.00955 61st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed ehang.io/nps (Go): 0.23.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ehang.io/nps (Go) | before 0.23.2 | 0.23.2 | Patch available | GHSA-2vp2-8m5j-4rjx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ehang.io/nps (Go) Vendor— Affected before 0.23.2 Fixed in 0.23.2 Patch available GHSA-2vp2-8m5j-4rjx
Remediation
- Fix · GHSA-2vp2-8m5j-4rjx ehang.io/nps (Go) Fixed in 0.23.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-15119
- 2026-10-03 Alias added: GHSA-2vp2-8m5j-4rjx
References
More Ehang-io Nps vulnerabilities
- TI-2022-19217 NPS before v0.26.10 was discovered to contain an authentication bypass vulnerability via… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-15119 · CVE Program
- CVE-2019-15119 · NVD
- FIRST EPSS
- GHSA-2vp2-8m5j-4rjx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences