In Octopus Deploy versions 2018.8.4 to 2019.7.6, when a web request proxy is configured…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-312.
Summary
In Octopus Deploy versions 2018.8.4 to 2019.7.6, when a web request proxy is configured, an authenticated user (in certain limited special-characters circumstances) could trigger a deployment that writes the web request proxy password to the deployment log in cleartext. This is fixed in 2019.7.7. The fix was back-ported to LTS 2019.6.7 as well as LTS 2019.3.8.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:server:*:*:*:*:*:*:*:* | 2018.8.4 – 2019.7.6 | Vulnerable | Octopus Deploy |
- cpe:2.3:a:octopus:server:*:*:*:*:*:*:*:* Versions 2018.8.4 – 2019.7.6 Vulnerable ·Octopus Deploy
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2019-15507
- 2026-10-03 Alias added: GHSA-48rh-rw8j-qvqv
- 2026-10-27 EPSS moved to the 50th–90th percentile
References
More Octopus Deploy Server vulnerabilities
- TI-2021-11814 Cleartext storage of sensitive information in Octopus Server CVSS 3.1HIGH 7.5
- TI-2021-11813 Cleartext storage of sensitive information in Octopus Server CVSS 3.1HIGH 7.5
- TI-2021-10722 Cleartext storage of sensitive information in multiple versions of Octopus Server where… CVSS 3.1HIGH 7.5
- TI-2019-11610 In Octopus Tentacle versions 3.0.8 to 5.0.0, when a web request proxy is configured, an… CVSS 3.0MEDIUM 6.5
- TI-2019-13770 A persistent cross-site scripting (XSS) vulnerability in Octopus Server 3.4.0 through… CVSS 3.1MEDIUM 5.4
- TI-2022-01375 Permissions were not properly verified in the API on projects using version control in… CVSS 3.1MEDIUM 4.3
Sources
- CVE-2019-15507 · CVE Program
- CVE-2019-15507 · NVD
- FIRST EPSS
- GHSA-48rh-rw8j-qvqv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences