connect-pg-simple before 6.0.1 allows SQL injection if tableName or schemaName is untrusted data.
Priority LOW 34CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
connect-pg-simple before 6.0.1 allows SQL injection if tableName or schemaName is untrusted data.
Why it matters now
EPSS 0.00981 62nd percentileScored 2026-11-07
Fix Fixed connect-pg-simple (npm): 6.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | connect-pg-simple (npm) | before 6.0.1 | 6.0.1 | Patch available | GHSA-xqh8-5j36-4556 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- connect-pg-simple (npm) Vendor— Affected before 6.0.1 Fixed in 6.0.1 Patch available GHSA-xqh8-5j36-4556
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:connect-pg-simple_project:connect-pg-simple:*:*:*:*:*:node.js:*:* | before 6.0.1 | Vulnerable | Connect-pg-simple Project |
- cpe:2.3:a:connect-pg-simple_project:connect-pg-simple:*:*:*:*:*:node.js:*:* Versions before 6.0.1 Vulnerable ·Connect-pg-simple Project
Remediation
- Fix · GHSA-xqh8-5j36-4556 connect-pg-simple (npm) Fixed in 6.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-15658
- 2026-10-03 Alias added: GHSA-xqh8-5j36-4556
References
Sources
- CVE-2019-15658 · CVE Program
- CVE-2019-15658 · NVD
- FIRST EPSS
- GHSA-xqh8-5j36-4556 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences