The Airbrake Ruby notifier 4.2.3 for Airbrake mishandles the blacklist_keys configuration…
Priority MEDIUM 45CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
The Airbrake Ruby notifier 4.2.3 for Airbrake mishandles the blacklist_keys configuration option and consequently may disclose passwords to unauthorized actors. This is fixed in 4.2.4 (also, 4.2.2 and earlier are unaffected).
Why it matters now
EPSS 0.01442 73rd percentileScored 2026-11-07
Fix Fixed airbrake-ruby (RubyGems): 4.2.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | airbrake-ruby (RubyGems) | 4.2.3 to before 4.2.4 | 4.2.4 | Patch available | GHSA-2p82-v77v-mppr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- airbrake-ruby (RubyGems) Vendor— Affected 4.2.3 to before 4.2.4 Fixed in 4.2.4 Patch available GHSA-2p82-v77v-mppr
Remediation
- Fix · GHSA-2p82-v77v-mppr airbrake-ruby (RubyGems) Fixed in 4.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-16060
- 2026-10-03 Alias added: GHSA-2p82-v77v-mppr
References
Sources
- CVE-2019-16060 · CVE Program
- CVE-2019-16060 · NVD
- FIRST EPSS
- GHSA-2p82-v77v-mppr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences