Validator parsing discrepancy due to string encoding in NPM slp-validate 1.0.0
Priority LOW 29CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the [email protected] npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. All versions >1.0.0 have been patched.
Why it matters now
EPSS 0.00993 62nd percentileScored 2026-11-07
Fix Fixed slp-validate (npm): 1.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| simpleledger | slp-validate | 1.0.0 | — | No fix listed | CNA |
| — | slp-validate (npm) | 1.0.0 to before 1.0.1 | 1.0.1 | Patch available | GHSA-wmx6-vxcf-c3gr |
- slp-validate Vendorsimpleledger Affected 1.0.0 Fixed in — No fix listed CNA
- slp-validate (npm) Vendor— Affected 1.0.0 to before 1.0.1 Fixed in 1.0.1 Patch available GHSA-wmx6-vxcf-c3gr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simpleledger:slp-validate:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | simpleledger |
- cpe:2.3:a:simpleledger:slp-validate:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·simpleledger
Remediation
- Fix · GHSA-wmx6-vxcf-c3gr slp-validate (npm) Fixed in 1.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-16761
- 2026-10-03 Alias added: GHSA-wmx6-vxcf-c3gr
References
Patch 2
Advisory 2
More simpleledger Slp-validate vulnerabilities
- TI-2020-08946 False-negative validation results in MINT transactions with invalid baton CVSS 3.1HIGH 8.6
- TI-2020-11904 False-positive validity for NFT1 genesis transactions in SLP Validate CVSS 3.1HIGH 7.5
Sources
- CVE-2019-16761 · CVE Program
- CVE-2019-16761 · NVD
- FIRST EPSS
- GHSA-wmx6-vxcf-c3gr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences