Affected versions of serialize-javascript are vulnerable to Cross-site Scripting (XSS)
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 2 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
The serialize-javascript npm package before version 2.1.1 is vulnerable to Cross-site Scripting (XSS). It does not properly mitigate against unsafe characters in serialized regular expressions. This vulnerability is not affected on Node.js environment since Node.js's implementation of RegExp.prototype.toString() backslash-escapes all forward slashes in regular expressions. If serialized data of regular expression objects are used in an environment other than Node.js, it is affected by this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| yahoo | serialize-javascript | < 2.1.1 to before 2.1.1 | 2.1.1 | Patch available | CNA |
| — | serialize-javascript (npm) | before 2.1.1 | 2.1.1 | Patch available | GHSA-h9rv-jmmf-4pgx |
- serialize-javascript Vendoryahoo Affected < 2.1.1 to before 2.1.1 Fixed in 2.1.1 Patch available CNA
- serialize-javascript (npm) Vendor— Affected before 2.1.1 Fixed in 2.1.1 Patch available GHSA-h9rv-jmmf-4pgx
Remediation
- Fix · CNA serialize-javascript (yahoo) Fixed in 2.1.1
- Fix · GHSA-h9rv-jmmf-4pgx serialize-javascript (npm) Fixed in 2.1.1 Advisory →
Red Hat 2 advisories
- RHSA-2020:4298 Released 2020-10-27 · Red Hat rating ModerateOpenShift Container Platform 4.6.1 image security update
- Red Hat OpenShift Container Platform 4.6 openshift4/ose-ansible-operator, openshift4/ose-aws-machine-controllers, openshift4/ose-azure-machine-controllers +47
- RHSA-2020:2796 Released 2020-07-01 · Red Hat rating ImportantRed Hat OpenShift Service Mesh servicemesh-grafana security update
- OpenShift Service Mesh 1.1 servicemesh-grafana-6.4.3-11.el8, servicemesh-grafana-prometheus-6.4.3-11.el8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Virtualization 1 | Affected | No fix planned: Will not fix |
| Red Hat Quay 3 | Affected | No fix planned: Will not fix |
| OpenShift Service Mesh 1.1 | Fixed | RHSA-2020:2796 |
| Red Hat OpenShift Container Platform 4.6 | Fixed | RHSA-2020:4298 |
Not affected: 1 product
- Red Hat OpenShift Container Platform 4.6
Timeline
- 2026-10-02 Threatist record created from CVE-2019-16769
- 2026-10-03 Alias added: GHSA-h9rv-jmmf-4pgx
References
More yahoo vulnerabilities
- TI-2007-03044 Buffer overflow in the Yahoo! Webcam Upload ActiveX control in ywcupl.dll 2.0.1.4 for… CVSS 2.0HIGH 9.3
- TI-2026-62497 CMAK through 3.0.0.6 Cross-Site Request Forgery via Missing CSRF Filter CVSS 4.0HIGH 7.2
- TI-2007-04373 Buffer overflow in a certain ActiveX control in YVerInfo.dll before 2007.8.27.1 in the… CVSS 2.0HIGH 9.3
- TI-2026-41720 Elide 7.1.17 - Permission Bypass in Sort Expression Validation CVSS 4.0MEDIUM 5.3
- TI-2007-03904 Stack-based buffer overflow in the YDPCTL.YDPControl.1 (aka Yahoo! Installer Plugin for… CVSS 2.0HIGH 9.3
- TI-2007-03045 Buffer overflow in the Yahoo! Webcam Viewer ActiveX control in ywcvwr.dll 2.0.1.4 for… CVSS 2.0HIGH 9.3
Sources
- CVE-2019-16769 · CVE Program
- CVE-2019-16769 · NVD
- FIRST EPSS
- GHSA-h9rv-jmmf-4pgx · GitHub Advisory Database · CC BY 4.0
- CVE-2019-16769 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences