In RubyGem excon, interrupted Persistent Connections May Leak Response Data
Priority LOW 30CWE-664Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
In RubyGem excon before 0.71.0, there was a race condition around persistent connections, where a connection which is interrupted (such as by a timeout) would leave data on the socket. Subsequent requests would then read this data, returning content from the previous response. The race condition window appears to be short, and it would be difficult to purposefully exploit this.
Why it matters now
EPSS 0.01662 76th percentileScored 2026-11-07
Fix Fixed excon (excon): 0.71.0excon (RubyGems): 0.71.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| excon | excon | < 0.71.0 to before 0.71.0 | 0.71.0 | Patch available | CNA |
| — | excon (RubyGems) | before 0.71.0 | 0.71.0 | Patch available | GHSA-q58g-455p-8vw9 |
- excon Vendorexcon Affected < 0.71.0 to before 0.71.0 Fixed in 0.71.0 Patch available CNA
- excon (RubyGems) Vendor— Affected before 0.71.0 Fixed in 0.71.0 Patch available GHSA-q58g-455p-8vw9
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:excon_project:excon:*:*:*:*:*:ruby:*:* | before 0.71.0 | Vulnerable | Excon Project |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* | 15.0 sp1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:excon_project:excon:*:*:*:*:*:ruby:*:* Versions before 0.71.0 Vulnerable ·Excon Project
- cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* Versions 15.0 sp1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · CNA excon (excon) Fixed in 0.71.0
- Fix · GHSA-q58g-455p-8vw9 excon (RubyGems) Fixed in 0.71.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-16779
- 2026-10-03 Alias added: GHSA-q58g-455p-8vw9
References
Advisory 5
Sources
- CVE-2019-16779 · CVE Program
- CVE-2019-16779 · NVD
- FIRST EPSS
- GHSA-q58g-455p-8vw9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences