Read the docs
TI-2019-12678 Aliases CVE-2019-16993GHSA-vj3x-vfm4-hvxc

In phpBB before 3.1.7-PL1, includes/acp/acp_bbcodes.php has improper verification of a…

Priority MEDIUM 40CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

In phpBB before 3.1.7-PL1, includes/acp/acp_bbcodes.php has improper verification of a CSRF token on the BBCode page in the Administration Control Panel. An actual CSRF attack is possible if an attacker also manages to retrieve the session id of a reauthenticated administrator prior to targeting them.

Why it matters now

EPSS 0.00804 56th percentileScored 2026-11-07
Fix Fixed phpbb/phpbb (Packagist): 3.1.7-PL1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—phpbb/phpbb (Packagist)before 3.1.7-PL13.1.7-PL1Patch availableGHSA-vj3x-vfm4-hvxc
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • phpbb/phpbb (Packagist) Vendor— Affected before 3.1.7-PL1 Fixed in 3.1.7-PL1 Patch available GHSA-vj3x-vfm4-hvxc

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:phpbb:phpbb:*:*:*:*:*:*:*:*up to 3.1.7VulnerablephpBB
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
  • cpe:2.3:a:phpbb:phpbb:*:*:*:*:*:*:*:* Versions up to 3.1.7 Vulnerable ·phpBB
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-vj3x-vfm4-hvxc phpbb/phpbb (Packagist) Fixed in 3.1.7-PL1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-16993
  2. 2026-10-03 Alias added: GHSA-vj3x-vfm4-hvxc

References

Sources