Read the docs
TI-2019-12978 Aliases CVE-2019-17383GHSA-49pj-69vf-c689

The netaddr gem before 2.0.4 for Ruby has misconfigured file permissions, such that a gem…

Priority MEDIUM 47CWE-276Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

The netaddr gem before 2.0.4 for Ruby has misconfigured file permissions, such that a gem install may result in 0777 permissions in the target filesystem.

Why it matters now

EPSS 0.02351 83rd percentileScored 2026-11-07
Fix Fixed netaddr (RubyGems): 2.0.4, 1.5.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—netaddr (RubyGems)2.0.0 to before 2.0.42.0.4Patch availableGHSA-49pj-69vf-c689
—netaddr (RubyGems)before 1.5.31.5.3Patch availableGHSA-49pj-69vf-c689
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • netaddr (RubyGems) Vendor— Affected 2.0.0 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-49pj-69vf-c689
  • netaddr (RubyGems) Vendor— Affected before 1.5.3 Fixed in 1.5.3 Patch available GHSA-49pj-69vf-c689

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:netaddr_project:netaddr:*:*:*:*:*:ruby:*:*1.5.0 to before 1.5.3; 2.0 to before 2.0.4VulnerableNetaddr Project
  • cpe:2.3:a:netaddr_project:netaddr:*:*:*:*:*:ruby:*:* Versions 1.5.0 to before 1.5.3; 2.0 to before 2.0.4 Vulnerable ·Netaddr Project

Remediation

  • Fix · GHSA-49pj-69vf-c689 netaddr (RubyGems) Fixed in 2.0.4 Advisory →
  • Fix · GHSA-49pj-69vf-c689 netaddr (RubyGems) Fixed in 1.5.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-17383
  2. 2026-10-03 Alias added: GHSA-49pj-69vf-c689

References

Sources