PAN-OS on PA-7000 Series: Improper restriction of communication to Log Forwarding Card (LFC) allows root access
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Improper restriction of communications to Log Forwarding Card (LFC) on PA-7000 Series devices with second-generation Switch Management Card (SMC) may allow an attacker with network access to the LFC to gain root access to PAN-OS. This issue affects PAN-OS 9.0 versions prior to 9.0.5-h3 on PA-7080 and PA-7050 devices with an LFC installed and configured. This issue does not affect PA-7000 Series deployments using the first-generation SMC and the Log Processing Card (LPC). This issue does not affect any other PA series devices. This issue does not affect devices without an LFC. This issue does not affect PAN-OS 8.1 or prior releases. This issue only affected a very limited number of customers and we undertook individual outreach to help them upgrade. At the time of publication, all identified customers have upgraded SW or content and are not impacted.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Palo Alto Networks | PAN-OS | 9.0 to before 9.0.5-h3 | 9.0.5-h3 | Patch available | CNA |
| Palo Alto Networks | PAN-OS | — | 8.0, 8.1 | Patch available | CNA |
- PAN-OS VendorPalo Alto Networks Affected 9.0 to before 9.0.5-h3 Fixed in 9.0.5-h3 Patch available CNA
- PAN-OS VendorPalo Alto Networks Affected — Fixed in 8.0, 8.1 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* | 9.0 – 9.0.5 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
| cpe:2.3:h:paloaltonetworks:pa-7050:-:*:*:*:*:*:*:* | not specified by NVD | Running on | CyberArk Software, a Palo Alto Networks Company |
| cpe:2.3:h:paloaltonetworks:pa-7080:-:*:*:*:*:*:*:* | not specified by NVD | Running on | CyberArk Software, a Palo Alto Networks Company |
- cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* Versions 9.0 – 9.0.5 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
- cpe:2.3:h:paloaltonetworks:pa-7050:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·CyberArk Software, a Palo Alto Networks Company
- cpe:2.3:h:paloaltonetworks:pa-7080:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·CyberArk Software, a Palo Alto Networks Company
Remediation
- Fix · CNA PAN-OS (Palo Alto Networks) Fixed in 9.0.5-h3
- Fix · CNA PAN-OS (Palo Alto Networks) Fixed in 8.0, 8.1
Timeline
- 2026-10-02 Threatist record created from CVE-2019-17440
- 2026-10-03 Alias added: GHSA-4w28-4cpv-vvf3
References
More Palo Alto Networks vulnerabilities
- TI-2024-08782 Expedition: Unauthenticated OS Command Injection Vulnerability Leads to Firewall Credential Disclosure KEVCVSS 4.0CRITICAL 9.9
- TI-2024-03172 PAN-OS: Arbitrary File Creation Leads to OS Command Injection Vulnerability in GlobalProtect KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01936 PAN-OS: Authentication Bypass in SAML Authentication KEVCVSS 3.1CRITICAL 10.0
- TI-2017-11675 Palo Alto Networks PAN-OS before 6.1.19, 7.0.x before 7.0.19, 7.1.x before 7.1.14, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-00239 PAN-OS: Unauthenticated user initiated Buffer Overflow Vulnerability in User-ID™ Authentication Portal KEVCVSS 4.0CRITICAL 9.3
- TI-2024-08784 Expedition: SQL Injection Leads to Firewall Admin Credential Disclosure KEVCVSS 4.0CRITICAL 9.2
Sources
- CVE-2019-17440 · CVE Program
- CVE-2019-17440 · NVD
- FIRST EPSS
- GHSA-4w28-4cpv-vvf3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences