In TypeStack class-validator 0.10.2, validate() input validation can be bypassed because…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting, SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79 and CWE-89.
Summary
In TypeStack class-validator 0.10.2, validate() input validation can be bypassed because certain internal attributes can be overwritten via a conflicting name. Even though there is an optional forbidUnknownValues parameter that can be used to reduce the risk of this bypass, this option is not documented and thus most developers configure input validation in the vulnerable default manner. With this vulnerability, attackers can launch SQL Injection or XSS attacks by injecting arbitrary malicious input. NOTE: a software maintainer agrees with the "is not documented" finding but suggests that much of the responsibility for the risk lies in a different product.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | class-validator (npm) | before 0.14.0 | 0.14.0 | Patch available | GHSA-fj58-h2fr-3pp2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- class-validator (npm) Vendor— Affected before 0.14.0 Fixed in 0.14.0 Patch available GHSA-fj58-h2fr-3pp2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:typestack_class-validator_project:typestack_class-validator:0.10.2:*:*:*:*:*:*:* | 0.10.2 | Vulnerable | Typestack Class-validator Project |
- cpe:2.3:a:typestack_class-validator_project:typestack_class-validator:0.10.2:*:*:*:*:*:*:* Versions 0.10.2 Vulnerable ·Typestack Class-validator Project
Remediation
- Fix · GHSA-fj58-h2fr-3pp2 class-validator (npm) Fixed in 0.14.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-18413
- 2026-10-03 Alias added: GHSA-fj58-h2fr-3pp2
References
Exploit 2
Advisory 3
Sources
- CVE-2019-18413 · CVE Program
- CVE-2019-18413 · NVD
- FIRST EPSS
- GHSA-fj58-h2fr-3pp2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences