Pimcore 6.2.3 has XSS in the translations grid because…
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Pimcore 6.2.3 has XSS in the translations grid because bundles/AdminBundle/Resources/public/js/pimcore/settings/translations.js mishandles certain HTML elements.
Why it matters now
EPSS 0.00679 52nd percentileScored 2026-11-07
Fix Fixed pimcore/pimcore (Packagist): 6.3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pimcore/pimcore (Packagist) | before 6.3.0 | 6.3.0 | Patch available | GHSA-65p8-5423-fw3x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pimcore/pimcore (Packagist) Vendor— Affected before 6.3.0 Fixed in 6.3.0 Patch available GHSA-65p8-5423-fw3x
Remediation
- Fix · GHSA-65p8-5423-fw3x pimcore/pimcore (Packagist) Fixed in 6.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-18656
- 2026-10-03 Alias added: GHSA-65p8-5423-fw3x
References
More Pimcore vulnerabilities
- TI-2026-18925 Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 CVSS 3.1HIGH 8.8
- TI-2026-18926 Pimcore ENV Variables and Cookie Informations are exposed in http_error_log CVSS 3.1HIGH 8.6
- TI-2023-01489 SQL Injection in pimcore/pimcore CVSS 3.1HIGH 8.8
- TI-2019-08091 An issue was discovered in Pimcore before 5.7.1. CVSS 3.0HIGH 8.8
- TI-2023-25778 SQL Injection in Admin Grid Filter API in Pimcore CVSS 3.1HIGH 8.8
- TI-2023-10682 An improper SameSite Attribute vulnerability in pimCore v10.5.15 allows attackers to execute arbitrary code. CVSS 3.1HIGH 8.8
Sources
- CVE-2019-18656 · CVE Program
- CVE-2019-18656 · NVD
- FIRST EPSS
- GHSA-65p8-5423-fw3x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences