Read the docs
TI-2019-13614 Aliases CVE-2019-18887GHSA-q8hg-pf8v-cxrv

An issue was discovered in Symfony 2.8.0 through 2.8.50, 3.4.0 through 3.4.34, 4.2.0…

Priority LOW 38CWE-203Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-203.

Summary

An issue was discovered in Symfony 2.8.0 through 2.8.50, 3.4.0 through 3.4.34, 4.2.0 through 4.2.11, and 4.3.0 through 4.3.7. The UriSigner was subject to timing attacks. This is related to symfony/http-kernel.

Why it matters now

EPSS 0.01338 71st percentileScored 2026-11-07
Fix Fixed symfony/http-kernel (Packagist): 2.8.52, 3.4.35, 4.2.12 +1symfony/symfony (Packagist): 2.8.52, 3.4.35, 4.2.12 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—symfony/http-kernel (Packagist)2.2.0 to before 2.8.522.8.52Patch availableGHSA-q8hg-pf8v-cxrv
—symfony/http-kernel (Packagist)3.0.0 to before 3.4.353.4.35Patch availableGHSA-q8hg-pf8v-cxrv
—symfony/http-kernel (Packagist)4.0.0 to before 4.2.124.2.12Patch availableGHSA-q8hg-pf8v-cxrv
—symfony/http-kernel (Packagist)4.3.0 to before 4.3.84.3.8Patch availableGHSA-q8hg-pf8v-cxrv
—symfony/symfony (Packagist)2.2.0 to before 2.8.522.8.52Patch availableGHSA-q8hg-pf8v-cxrv
—symfony/symfony (Packagist)3.0.0 to before 3.4.353.4.35Patch availableGHSA-q8hg-pf8v-cxrv
—symfony/symfony (Packagist)4.0.0 to before 4.2.124.2.12Patch availableGHSA-q8hg-pf8v-cxrv
—symfony/symfony (Packagist)4.3.0 to before 4.3.84.3.8Patch availableGHSA-q8hg-pf8v-cxrv
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • symfony/http-kernel (Packagist) Vendor— Affected 2.2.0 to before 2.8.52 Fixed in 2.8.52 Patch available GHSA-q8hg-pf8v-cxrv
  • symfony/http-kernel (Packagist) Vendor— Affected 3.0.0 to before 3.4.35 Fixed in 3.4.35 Patch available GHSA-q8hg-pf8v-cxrv
  • symfony/http-kernel (Packagist) Vendor— Affected 4.0.0 to before 4.2.12 Fixed in 4.2.12 Patch available GHSA-q8hg-pf8v-cxrv
  • symfony/http-kernel (Packagist) Vendor— Affected 4.3.0 to before 4.3.8 Fixed in 4.3.8 Patch available GHSA-q8hg-pf8v-cxrv
  • symfony/symfony (Packagist) Vendor— Affected 2.2.0 to before 2.8.52 Fixed in 2.8.52 Patch available GHSA-q8hg-pf8v-cxrv
  • symfony/symfony (Packagist) Vendor— Affected 3.0.0 to before 3.4.35 Fixed in 3.4.35 Patch available GHSA-q8hg-pf8v-cxrv
  • symfony/symfony (Packagist) Vendor— Affected 4.0.0 to before 4.2.12 Fixed in 4.2.12 Patch available GHSA-q8hg-pf8v-cxrv
  • symfony/symfony (Packagist) Vendor— Affected 4.3.0 to before 4.3.8 Fixed in 4.3.8 Patch available GHSA-q8hg-pf8v-cxrv

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:*2.8.0 – 2.8.50; 3.4.0 – 3.4.34; 4.2.0 – 4.2.11; 4.3.0 – 4.3.7Vulnerablesensiolabs
cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:*30VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:*31VulnerableFedoraproject
  • cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 2.8.0 – 2.8.50; 3.4.0 – 3.4.34; 4.2.0 – 4.2.11; 4.3.0 – 4.3.7 Vulnerable ·sensiolabs
  • cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject

Remediation

  • Fix · GHSA-q8hg-pf8v-cxrv symfony/http-kernel (Packagist) Fixed in 2.8.52 Advisory →
  • Fix · GHSA-q8hg-pf8v-cxrv symfony/http-kernel (Packagist) Fixed in 3.4.35 Advisory →
  • Fix · GHSA-q8hg-pf8v-cxrv symfony/http-kernel (Packagist) Fixed in 4.2.12 Advisory →
  • Fix · GHSA-q8hg-pf8v-cxrv symfony/http-kernel (Packagist) Fixed in 4.3.8 Advisory →
  • Fix · GHSA-q8hg-pf8v-cxrv symfony/symfony (Packagist) Fixed in 2.8.52 Advisory →
  • Fix · GHSA-q8hg-pf8v-cxrv symfony/symfony (Packagist) Fixed in 3.4.35 Advisory →
  • Fix · GHSA-q8hg-pf8v-cxrv symfony/symfony (Packagist) Fixed in 4.2.12 Advisory →
  • Fix · GHSA-q8hg-pf8v-cxrv symfony/symfony (Packagist) Fixed in 4.3.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-18887
  2. 2026-10-03 Alias added: GHSA-q8hg-pf8v-cxrv

References

Sources