trousers: Local privilege escalation from tss to root
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
UNIX Symbolic Link (Symlink) Following vulnerability in the trousers package of SUSE Linux Enterprise Server 15 SP1; openSUSE Factory allowed local attackers escalate privileges from user tss to root. This issue affects: SUSE Linux Enterprise Server 15 SP1 trousers versions prior to 0.3.14-6.3.1. openSUSE Factory trousers versions prior to 0.3.14-7.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | SUSE Linux Enterprise Server 15 SP1 | trousers to before 0.3.14-6.3.1 | 0.3.14-6.3.1 | Patch available | CNA |
| openSUSE | Factory | trousers to before 0.3.14-7.1 | 0.3.14-7.1 | Patch available | CNA |
- SUSE Linux Enterprise Server 15 SP1 VendorSUSE Affected trousers to before 0.3.14-6.3.1 Fixed in 0.3.14-6.3.1 Patch available CNA
- Factory VendoropenSUSE Affected trousers to before 0.3.14-7.1 Fixed in 0.3.14-7.1 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:suse:trousers:*:*:*:*:*:*:*:* | before 0.3.14-6.3.1 | Vulnerable | SUSE |
| cpe:2.3:o:suse:suse_linux_enterprise_server:15:sp1:*:*:*:*:*:* | 15 sp1 | Running on | SUSE |
| cpe:2.3:a:suse:trousers:*:*:*:*:*:*:*:* | before 0.3.14-7.1 | Vulnerable | SUSE |
| cpe:2.3:o:suse:opensuse_factory:-:*:*:*:*:*:*:* | not specified by NVD | Running on | SUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
- cpe:2.3:a:suse:trousers:*:*:*:*:*:*:*:* Versions before 0.3.14-6.3.1 Vulnerable ·SUSE
- cpe:2.3:o:suse:suse_linux_enterprise_server:15:sp1:*:*:*:*:*:* Versions 15 sp1 Running on ·SUSE
- cpe:2.3:a:suse:trousers:*:*:*:*:*:*:*:* Versions before 0.3.14-7.1 Vulnerable ·SUSE
- cpe:2.3:o:suse:opensuse_factory:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·SUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
Remediation
- Fix · CNA SUSE Linux Enterprise Server 15 SP1 (SUSE) Fixed in 0.3.14-6.3.1
- Fix · CNA Factory (openSUSE) Fixed in 0.3.14-7.1
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2019-18898
- 2026-10-03 Alias added: GHSA-w5w4-523j-qm3v
References
Advisory 1
Sources
- CVE-2019-18898 · CVE Program
- CVE-2019-18898 · NVD
- FIRST EPSS
- GHSA-w5w4-523j-qm3v · GitHub Advisory Database · CC BY 4.0
- CVE-2019-18898 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences