apt-cacher-ng insecure use of /run/apt-cacher-ng
Priority LOW 27CWE-269Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
The apt-cacher-ng package of openSUSE Leap 15.1 runs operations in user owned directory /run/apt-cacher-ng with root privileges. This can allow local attackers to influence the outcome of these operations. This issue affects: openSUSE Leap 15.1 apt-cacher-ng versions prior to 3.1-lp151.3.3.1.
Why it matters now
EPSS 0.00264 18th percentileScored 2026-11-07
Fix Fixed Leap 15.1 (openSUSE): 3.1-lp151.3.3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| openSUSE | Leap 15.1 | apt-cacher-ng to before 3.1-lp151.3.3.1 | 3.1-lp151.3.3.1 | Patch available | CNA |
- Leap 15.1 VendoropenSUSE Affected apt-cacher-ng to before 3.1-lp151.3.3.1 Fixed in 3.1-lp151.3.3.1 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apt-cacher-ng_project:apt-cacher-ng:*:*:*:*:*:*:*:* | before 3.1-lp151.3.3.1 | Vulnerable | Apt-cacher-ng Project |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Running on | openSUSE |
| cpe:2.3:o:opensuse:backports:sle-15:sp1:*:*:*:*:*:* | sle-15 sp1 | Vulnerable | openSUSE |
- cpe:2.3:a:apt-cacher-ng_project:apt-cacher-ng:*:*:*:*:*:*:*:* Versions before 3.1-lp151.3.3.1 Vulnerable ·Apt-cacher-ng Project
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Running on ·openSUSE
- cpe:2.3:o:opensuse:backports:sle-15:sp1:*:*:*:*:*:* Versions sle-15 sp1 Vulnerable ·openSUSE
Remediation
- Fix · CNA Leap 15.1 (openSUSE) Fixed in 3.1-lp151.3.3.1
Timeline
- 2026-10-02 Threatist record created from CVE-2019-18899
- 2026-10-03 Alias added: GHSA-fv3j-23hh-g3xf
References
More openSUSE Backports vulnerabilities
- TI-2018-14299 rdesktop versions up to and including v1.8.3 contain an Integer Overflow that leads to a… CVSS 3.1CRITICAL 9.8
- TI-2020-12438 Zabbix before 3.0.32rc1, 4.x before 4.0.22rc1, 4.1.x through 4.4.x before 4.4.10rc1, and… CVSS 3.1MEDIUM 6.1
- TI-2020-08819 GraphicsMagick before 1.3.35 has an integer overflow and resultant heap-based buffer… CVSS 3.1CRITICAL 9.8
- TI-2019-04101 Integer overflow in Google Chrome CVSS 3.1HIGH 8.8
- TI-2019-04100 Integer overflow in Google Chrome CVSS 3.1HIGH 8.8
- TI-2018-14079 An issue was discovered in Qt before 5.11.3. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-18899 · CVE Program
- CVE-2019-18899 · NVD
- FIRST EPSS
- GHSA-fv3j-23hh-g3xf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences