libzypp stores cookies world readable
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
: Incorrect Default Permissions vulnerability in libzypp of SUSE CaaS Platform 3.0, SUSE Linux Enterprise Server 12, SUSE Linux Enterprise Server 15 allowed local attackers to read a cookie store used by libzypp, exposing private cookies. This issue affects: SUSE CaaS Platform 3.0 libzypp versions prior to 16.21.2-27.68.1. SUSE Linux Enterprise Server 12 libzypp versions prior to 16.21.2-2.45.1. SUSE Linux Enterprise Server 15 17.19.0-3.34.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | CaaS Platform 3.0 | libzypp to before 16.21.2-27.68.1 | 16.21.2-27.68.1 | Patch available | CNA |
| SUSE | SUSE Linux Enterprise Server 12 | libzypp to before 16.21.2-2.45.1 | 16.21.2-2.45.1 | Patch available | CNA |
| SUSE | SUSE Linux Enterprise Server 15 | libzypp 17.19.0-3.34.1 | — | No fix listed | CNA |
- CaaS Platform 3.0 VendorSUSE Affected libzypp to before 16.21.2-27.68.1 Fixed in 16.21.2-27.68.1 Patch available CNA
- SUSE Linux Enterprise Server 12 VendorSUSE Affected libzypp to before 16.21.2-2.45.1 Fixed in 16.21.2-2.45.1 Patch available CNA
- SUSE Linux Enterprise Server 15 VendorSUSE Affected libzypp 17.19.0-3.34.1 Fixed in — No fix listed CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opensuse:libzypp:*:*:*:*:*:*:*:* | before 16.21.2-27.68.1 | Vulnerable | openSUSE |
| cpe:2.3:o:suse:caas_platform:3.0:*:*:*:*:*:*:* | 3.0 | Running on | SUSE |
| cpe:2.3:a:opensuse:libzypp:*:*:*:*:*:*:*:* | before 16.21.2-2.45.1 | Vulnerable | openSUSE |
| cpe:2.3:o:suse:suse_linux_enterprise_server:12:*:*:*:*:*:*:* | 12 | Running on | SUSE |
| cpe:2.3:a:opensuse:libzypp:*:*:*:*:*:*:*:* | before 17.19.0-3.34.1 | Vulnerable | openSUSE |
| cpe:2.3:o:suse:suse_linux_enterprise_server:15:*:*:*:*:*:*:* | 15 | Running on | SUSE |
- cpe:2.3:a:opensuse:libzypp:*:*:*:*:*:*:*:* Versions before 16.21.2-27.68.1 Vulnerable ·openSUSE
- cpe:2.3:o:suse:caas_platform:3.0:*:*:*:*:*:*:* Versions 3.0 Running on ·SUSE
- cpe:2.3:a:opensuse:libzypp:*:*:*:*:*:*:*:* Versions before 16.21.2-2.45.1 Vulnerable ·openSUSE
- cpe:2.3:o:suse:suse_linux_enterprise_server:12:*:*:*:*:*:*:* Versions 12 Running on ·SUSE
- cpe:2.3:a:opensuse:libzypp:*:*:*:*:*:*:*:* Versions before 17.19.0-3.34.1 Vulnerable ·openSUSE
- cpe:2.3:o:suse:suse_linux_enterprise_server:15:*:*:*:*:*:*:* Versions 15 Running on ·SUSE
Remediation
- Fix · CNA CaaS Platform 3.0 (SUSE) Fixed in 16.21.2-27.68.1
- Fix · CNA SUSE Linux Enterprise Server 12 (SUSE) Fixed in 16.21.2-2.45.1
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-18900
- 2026-10-03 Alias added: GHSA-fp7r-722w-q34j
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-18900 · CVE Program
- CVE-2019-18900 · NVD
- FIRST EPSS
- GHSA-fp7r-722w-q34j · GitHub Advisory Database · CC BY 4.0
- CVE-2019-18900 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences