Read the docs
TI-2019-13673 Aliases CVE-2019-18978GHSA-pf8f-w267-mq2h

An issue was discovered in the rack-cors (aka Rack CORS Middleware) gem before 1.0.4 for…

Priority LOW 29CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.

Summary

An issue was discovered in the rack-cors (aka Rack CORS Middleware) gem before 1.0.4 for Ruby. It allows ../ directory traversal to access private resources because resource matching does not ensure that pathnames are in a canonical format.

Why it matters now

EPSS 0.02462 84th percentileScored 2026-11-07
Fix Fixed rack-cors (RubyGems): 1.0.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—rack-cors (RubyGems)before 1.0.41.0.4Patch availableGHSA-pf8f-w267-mq2h
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • rack-cors (RubyGems) Vendor— Affected before 1.0.4 Fixed in 1.0.4 Patch available GHSA-pf8f-w267-mq2h

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:rack-cors_project:rack-cors:*:*:*:*:*:ruby:*:*before 1.0.4VulnerableRack-cors Project
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:*16.04VulnerableCanonical
  • cpe:2.3:a:rack-cors_project:rack-cors:*:*:*:*:*:ruby:*:* Versions before 1.0.4 Vulnerable ·Rack-cors Project
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
  • cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:* Versions 16.04 Vulnerable ·Canonical

Remediation

  • Fix · GHSA-pf8f-w267-mq2h rack-cors (RubyGems) Fixed in 1.0.4 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-18978
  2. 2026-10-03 Alias added: GHSA-pf8f-w267-mq2h

References

Sources