Wowza Streaming Engine before 4.8.5 has Insecure Permissions which may allow a local…
Priority LOW 34CWE-732Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Wowza Streaming Engine before 4.8.5 has Insecure Permissions which may allow a local attacker to escalate privileges in / usr / local / WowzaStreamingEngine / manager / bin / in the Linux version of the server by writing arbitrary commands in any file and execute them as root. This issue was resolved in Wowza Streaming Engine 4.8.5.
Why it matters now
EPSS 0.00372 31st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2019-19455
- 2026-10-03 Alias added: GHSA-wqmj-9hmf-rw4x
References
More Wowza Streaming Engine vulnerabilities
- TI-2016-09210 Wowza Streaming Engine 4.5.0 Privilege Escalation via user edit CVSS 4.0HIGH 8.7
- TI-2016-09209 Wowza Streaming Engine 4.5.0 Local Privilege Escalation via nssm_x64.exe CVSS 4.0HIGH 8.5
- TI-2016-09211 Wowza Streaming Engine 4.5.0 CSRF via user edit endpoint CVSS 4.0MEDIUM 6.9
- TI-2018-13723 The REST API in Wowza Streaming Engine 4.7.4.01 allows traversal of the directory… CVSS 3.1CRITICAL 9.1
- TI-2016-09212 Wowza Streaming Engine 4.5.0 Multiple Cross-Site Scripting Vulnerabilities CVSS 4.0MEDIUM 5.1
- TI-2018-05112 An issue was discovered in the MBeans Server in Wowza Streaming Engine before 4.7.1. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2019-19455 · CVE Program
- CVE-2019-19455 · NVD
- FIRST EPSS
- GHSA-wqmj-9hmf-rw4x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences