Read the docs
TI-2019-14203 Aliases CVE-2019-19709GHSA-pjv5-vv93-p648

MediaWiki through 1.33.1 allows attackers to bypass the Title_blacklist protection…

Priority LOW 30CWE-601Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Spoofing
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-601.

Summary

MediaWiki through 1.33.1 allows attackers to bypass the Title_blacklist protection mechanism by starting with an arbitrary title, establishing a non-resolvable redirect for the associated page, and using redirect=1 in the action API when editing that page.

Why it matters now

EPSS 0.01564 75th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed mediawiki/core (Packagist): 1.31.6, 1.32.6, 1.33.2 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mediawiki/core (Packagist)1.31.0 to before 1.31.61.31.6Patch availableGHSA-pjv5-vv93-p648
—mediawiki/core (Packagist)1.32.0 to before 1.32.61.32.6Patch availableGHSA-pjv5-vv93-p648
—mediawiki/core (Packagist)1.33.0 to before 1.33.21.33.2Patch availableGHSA-pjv5-vv93-p648
—mediawiki/core (Packagist)1.33.99 to before 1.34.01.34.0Patch availableGHSA-pjv5-vv93-p648
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mediawiki/core (Packagist) Vendor— Affected 1.31.0 to before 1.31.6 Fixed in 1.31.6 Patch available GHSA-pjv5-vv93-p648
  • mediawiki/core (Packagist) Vendor— Affected 1.32.0 to before 1.32.6 Fixed in 1.32.6 Patch available GHSA-pjv5-vv93-p648
  • mediawiki/core (Packagist) Vendor— Affected 1.33.0 to before 1.33.2 Fixed in 1.33.2 Patch available GHSA-pjv5-vv93-p648
  • mediawiki/core (Packagist) Vendor— Affected 1.33.99 to before 1.34.0 Fixed in 1.34.0 Patch available GHSA-pjv5-vv93-p648

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:*up to 1.33.1Vulnerablemediawiki
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
  • cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions up to 1.33.1 Vulnerable ·mediawiki
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-pjv5-vv93-p648 mediawiki/core (Packagist) Fixed in 1.31.6 Advisory →
  • Fix · GHSA-pjv5-vv93-p648 mediawiki/core (Packagist) Fixed in 1.32.6 Advisory →
  • Fix · GHSA-pjv5-vv93-p648 mediawiki/core (Packagist) Fixed in 1.33.2 Advisory →
  • Fix · GHSA-pjv5-vv93-p648 mediawiki/core (Packagist) Fixed in 1.34.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-19709
  2. 2026-10-03 Alias added: GHSA-pjv5-vv93-p648

References

Sources