Read the docs
TI-2019-14684 Aliases CVE-2019-20455GHSA-pm77-c4q7-3fwj

Gateways/Gateway.php in Heartland & Global Payments PHP SDK before 2.0.0 does not enforce SSL certificate validations.

Priority LOW 28CWE-295Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Spoofing
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-295.

Summary

Gateways/Gateway.php in Heartland & Global Payments PHP SDK before 2.0.0 does not enforce SSL certificate validations.

Why it matters now

EPSS 0.00976 62nd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed globalpayments/php-sdk (Packagist): 2.0.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—globalpayments/php-sdk (Packagist)before 2.0.02.0.0Patch availableGHSA-pm77-c4q7-3fwj
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • globalpayments/php-sdk (Packagist) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-pm77-c4q7-3fwj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:globalpayments:php_sdk:*:*:*:*:*:*:*:*before 2.0.0VulnerableGlobal Payments
  • cpe:2.3:a:globalpayments:php_sdk:*:*:*:*:*:*:*:* Versions before 2.0.0 Vulnerable ·Global Payments

Remediation

  • Fix · GHSA-pm77-c4q7-3fwj globalpayments/php-sdk (Packagist) Fixed in 2.0.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-20455
  2. 2026-10-03 Alias added: GHSA-pm77-c4q7-3fwj

References

Sources