Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution.
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Partial Red Hat: 4 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-94.
Summary
Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. The lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript. This can be used to run arbitrary code on a server processing Handlebars templates or in a victim's browser (effectively serving as XSS).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | handlebars (npm) | before 3.0.8 | 3.0.8 | Patch available | GHSA-3cqr-58rm-57f8 |
| — | handlebars (npm) | 4.0.0 to before 4.5.3 | 4.5.3 | Patch available | GHSA-3cqr-58rm-57f8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- handlebars (npm) Vendor— Affected before 3.0.8 Fixed in 3.0.8 Patch available GHSA-3cqr-58rm-57f8
- handlebars (npm) Vendor— Affected 4.0.0 to before 4.5.3 Fixed in 4.5.3 Patch available GHSA-3cqr-58rm-57f8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:handlebarsjs:handlebars:*:*:*:*:*:node.js:*:* | before 3.0.8; 4.0.0 to before 4.5.3 | Vulnerable | handlebars-lang |
- cpe:2.3:a:handlebarsjs:handlebars:*:*:*:*:*:node.js:*:* Versions before 3.0.8; 4.0.0 to before 4.5.3 Vulnerable ·handlebars-lang
Remediation
- Fix · GHSA-3cqr-58rm-57f8 handlebars (npm) Fixed in 3.0.8 Advisory →
- Fix · GHSA-3cqr-58rm-57f8 handlebars (npm) Fixed in 4.5.3 Advisory →
Red Hat 4 advisories
- RHSA-2023:1334 Released 2023-03-20 · Red Hat rating CriticalRed Hat Process Automation Manager 7.13.2 security update
- RHPAM 7.13.1 async
- RHSA-2021:3917 Released 2021-10-19 · Red Hat rating ImportantRed Hat Quay v3.6.0 security, bug fix and enhancement update
- Quay v3 quay/quay-rhel8
- RHSA-2021:2500 Released 2021-06-29 · Red Hat rating ModerateRed Hat OpenShift Enterprise security and bug fix update
- Red Hat OpenShift Container Platform 4.6 openshift4/ose-logging-kibana6
Show 1 more Red Hat advisories
- RHSA-2020:5179 Released 2020-11-24 · Red Hat rating LowRed Hat Virtualization security, bug fix, and enhancement update
- RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4 ovirt-engine-4.4.3.8-0.1.el8ev, ovirt-engine-backend-4.4.3.8-0.1.el8ev, ovirt-engine-dbscripts-4.4.3.8-0.1.el8ev +18
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Service Mesh 1 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 4 | Affected | No fix planned: Will not fix |
| Quay v3 | Fixed | RHSA-2021:3917 |
| RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4 | Fixed | RHSA-2020:5179 |
| RHPAM 7.13.1 async | Fixed | RHSA-2023:1334 |
| Red Hat OpenShift Container Platform 4.6 | Fixed | RHSA-2021:2500 |
Not affected: 6 products
- OpenShift Service Mesh 1
- Quay v3
- RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4
- Red Hat Advanced Cluster Management for Kubernetes 2
- Red Hat OpenShift Container Platform 4.6
- Red Hat Virtualization 4
Timeline
- 2026-10-02 Threatist record created from CVE-2019-20920
- 2026-10-03 Alias added: GHSA-3cqr-58rm-57f8
- 2026-10-08 CISA SSVC decision points changed
References
More handlebars-lang Handlebars vulnerabilities
- TI-2026-26288 Handlebars.js has JavaScript Injection via AST Type Confusion CVSS 3.1CRITICAL 9.8
- TI-2026-26290 Handlebars.js has Denial of Service via Malformed Decorator Syntax in Template Compilation CVSS 3.1HIGH 7.5
- TI-2026-26292 Handlebars.js has JavaScript Injection in CLI Precompiler via Unescaped Names and Options CVSS 3.1HIGH 8.3
- TI-2026-26291 Handlebars.js has JavaScript Injection via AST Type Confusion when passing an object as dynamic partial CVSS 3.1HIGH 8.1
- TI-2026-26289 Handlebars.js has JavaScript Injection via AST Type Confusion by tampering @partial-block CVSS 3.1HIGH 8.1
- TI-2021-06062 Remote code execution (RCE) in handlebars CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-20920 · CVE Program
- CVE-2019-20920 · NVD
- FIRST EPSS
- GHSA-3cqr-58rm-57f8 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-20920 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences