bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS).
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 1 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.
Why it matters now
EPSS 0.01738 77th percentileScored 2026-11-07
Fix Partial bootstrap-select (npm): 1.13.6bootstrap-select (NuGet): 1.13.6Red Hat: 2 advisoriesRed Hat: 1 fixed, 3 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | bootstrap-select (npm) | before 1.13.6 | 1.13.6 | Patch available | GHSA-7c82-mp33-r854 |
| — | bootstrap-select (NuGet) | before 1.13.6 | 1.13.6 | Patch available | GHSA-7c82-mp33-r854 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- bootstrap-select (npm) Vendor— Affected before 1.13.6 Fixed in 1.13.6 Patch available GHSA-7c82-mp33-r854
- bootstrap-select (NuGet) Vendor— Affected before 1.13.6 Fixed in 1.13.6 Patch available GHSA-7c82-mp33-r854
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:snapappointments:bootstrap-select:*:*:*:*:*:node.js:*:* | before 1.13.6 | Vulnerable | Snapappointments |
- cpe:2.3:a:snapappointments:bootstrap-select:*:*:*:*:*:node.js:*:* Versions before 1.13.6 Vulnerable ·Snapappointments
Remediation
- Fix · GHSA-7c82-mp33-r854 bootstrap-select (npm) Fixed in 1.13.6 Advisory →
- Fix · GHSA-7c82-mp33-r854 bootstrap-select (NuGet) Fixed in 1.13.6 Advisory →
Red Hat 2 advisories
- RHSA-2021:1169 Released 2021-04-14 · Red Hat rating ModerateRHV Manager (ovirt-engine) 4.4.z [ovirt-4.4.5] security, bug fix, enhancement
- RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4 ovirt-engine-4.4.5.9-0.1.el8ev, ovirt-engine-backend-4.4.5.9-0.1.el8ev, ovirt-engine-dbscripts-4.4.5.9-0.1.el8ev +18
- RHSA-2021:1186 Released 2021-04-14 · Red Hat rating ModerateRHV Manager (ovirt-engine) 4.4.z [ovirt-4.4.5] 0-day security, bug fix, enhance
- RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4 ovirt-engine-ui-extensions-1.2.5-1.el8ev
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Service Mesh 1 | Affected | No fix yet: Fix deferred |
| Red Hat Single Sign-On 7 | Affected | No fix planned: Will not fix |
| Red Hat Virtualization 4 | Affected | No fix planned: Will not fix |
| RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4 | Fixed | RHSA-2021:1169, RHSA-2021:1186 |
Not affected: 3 products
- RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4
- Red Hat OpenShift Container Platform 3.11
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2019-20921
- 2026-10-03 Alias added: GHSA-7c82-mp33-r854
References
Advisory 3
Sources
- CVE-2019-20921 · CVE Program
- CVE-2019-20921 · NVD
- FIRST EPSS
- GHSA-7c82-mp33-r854 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-20921 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences