InfluxDB before 1.7.6 has an authentication bypass vulnerability in the authenticate…
Priority HIGH 66CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
InfluxDB before 1.7.6 has an authentication bypass vulnerability in the authenticate function in services/httpd/handler.go because a JWT token may have an empty SharedSecret (aka shared secret).
Why it matters now
EPSS 0.30921 98th percentileScored 2026-11-07
Fix Fixed github.com/influxdata/influxdb (Go): 1.7.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/influxdata/influxdb (Go) | before 1.7.6 | 1.7.6 | Patch available | GHSA-2rmp-fw5r-j5qv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/influxdata/influxdb (Go) Vendor— Affected before 1.7.6 Fixed in 1.7.6 Patch available GHSA-2rmp-fw5r-j5qv
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:influxdata:influxdb:*:*:*:*:*:*:*:* | before 1.7.6 | Vulnerable | Influxdata |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:influxdata:influxdb:*:*:*:*:*:*:*:* Versions before 1.7.6 Vulnerable ·Influxdata
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-2rmp-fw5r-j5qv github.com/influxdata/influxdb (Go) Fixed in 1.7.6 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 8 products
- Distributed Tracing Jaeger 1
- OpenShift Service Mesh 1
- OpenShift Service Mesh 2.0
- Red Hat Advanced Cluster Management for Kubernetes 2
- Red Hat Fuse 7
- Red Hat Integration Camel K 1
- Red Hat JBoss Fuse 6
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2019-20933
- 2026-10-03 Alias added: GHSA-2rmp-fw5r-j5qv
References
Patch 2
Advisory 4
Sources
- CVE-2019-20933 · CVE Program
- CVE-2019-20933 · NVD
- FIRST EPSS
- GHSA-2rmp-fw5r-j5qv · GitHub Advisory Database · CC BY 4.0
- CVE-2019-20933 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences