Stored cross-site scripting in Grid component in Vaadin 7 and 8
Priority LOW 29CWE-80Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-80.
Summary
Missing variable sanitization in Grid component in com.vaadin:vaadin-server versions 7.4.0 through 7.7.19 (Vaadin 7.4.0 through 7.7.19), and 8.0.0 through 8.8.4 (Vaadin 8.0.0 through 8.8.4) allows attacker to inject malicious JavaScript via unspecified vector
Why it matters now
EPSS 0.00923 60th percentileScored 2026-11-07
Fix Fixed com.vaadin:vaadin-bom (Maven): 7.7.20, 8.8.5com.vaadin:vaadin-server (Maven): 7.7.20, 8.8.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Vaadin | Vaadin | 7.4.0 and later | — | No fix listed | CNA |
| Vaadin | vaadin-server | 7.4.0 and later | — | No fix listed | CNA |
| — | com.vaadin:vaadin-bom (Maven) | 7.4.0 to before 7.7.20 | 7.7.20 | Patch available | GHSA-q74r-4xw3-ppx9 |
| — | com.vaadin:vaadin-bom (Maven) | 8.0.0 to before 8.8.5 | 8.8.5 | Patch available | GHSA-q74r-4xw3-ppx9 |
| — | com.vaadin:vaadin-server (Maven) | 7.4.0 to before 7.7.20 | 7.7.20 | Patch available | GHSA-q74r-4xw3-ppx9 |
| — | com.vaadin:vaadin-server (Maven) | 8.0.0 to before 8.8.5 | 8.8.5 | Patch available | GHSA-q74r-4xw3-ppx9 |
- Vaadin VendorVaadin Affected 7.4.0 and later Fixed in — No fix listed CNA
- vaadin-server VendorVaadin Affected 7.4.0 and later Fixed in — No fix listed CNA
- com.vaadin:vaadin-bom (Maven) Vendor— Affected 7.4.0 to before 7.7.20 Fixed in 7.7.20 Patch available GHSA-q74r-4xw3-ppx9
- com.vaadin:vaadin-bom (Maven) Vendor— Affected 8.0.0 to before 8.8.5 Fixed in 8.8.5 Patch available GHSA-q74r-4xw3-ppx9
- com.vaadin:vaadin-server (Maven) Vendor— Affected 7.4.0 to before 7.7.20 Fixed in 7.7.20 Patch available GHSA-q74r-4xw3-ppx9
- com.vaadin:vaadin-server (Maven) Vendor— Affected 8.0.0 to before 8.8.5 Fixed in 8.8.5 Patch available GHSA-q74r-4xw3-ppx9
Remediation
- Fix · GHSA-q74r-4xw3-ppx9 com.vaadin:vaadin-bom (Maven) Fixed in 7.7.20 Advisory →
- Fix · GHSA-q74r-4xw3-ppx9 com.vaadin:vaadin-bom (Maven) Fixed in 8.8.5 Advisory →
- Fix · GHSA-q74r-4xw3-ppx9 com.vaadin:vaadin-server (Maven) Fixed in 7.7.20 Advisory →
- Fix · GHSA-q74r-4xw3-ppx9 com.vaadin:vaadin-server (Maven) Fixed in 8.8.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-25028
- 2026-10-03 Alias added: GHSA-q74r-4xw3-ppx9
References
More Vaadin vulnerabilities
- TI-2021-11539 Server classes and resources exposure in OSGi applications using Vaadin 12-14 and 19 CVSS 3.1HIGH 8.6
- TI-2020-18603 Regular expression Denial of Service (ReDoS) in EmailValidator class in Vaadin 7 CVSS 3.1HIGH 7.5
- TI-2021-11541 Server session is not invalidated when logout() helper method of Authentication module is used in Vaadin 18-19 CVSS 3.1HIGH 7.5
- TI-2022-12014 Possible information disclosure inside TreeGrid component with default data provider CVSS 3.1HIGH 7.5
- TI-2021-11537 Regular expression denial of service (ReDoS) in EmailField component in Vaadin 14 and 15-17 CVSS 3.1HIGH 7.5
- TI-2020-18604 Directory traversal in development mode handler in Vaadin 14 and 15-17 CVSS 3.1HIGH 7.5
Sources
- CVE-2019-25028 · CVE Program
- CVE-2019-25028 · NVD
- FIRST EPSS
- GHSA-q74r-4xw3-ppx9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences