Easy WP SMTP <= 1.3.9 - Missing Authorization to Arbitrary Options Update
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Easy WP SMTP plugin for WordPress is vulnerable to authorization bypass in versions up to, and including, 1.3.9. This is due to missing capability checks on the admin_init() function, in addition to insufficient input validation. This makes it possible for unauthenticated attackers to modify the plugins settings and arbitrary options on the site that can be used to inject new administrative user accounts.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| smub | Easy WP SMTP – WordPress SMTP and Email Logs: Gmail, Office 365, Outlook, Custom SMTP, and more | before 1.3.9.1 | 1.3.9.1 | Patch available | CNA |
- Easy WP SMTP – WordPress SMTP and Email Logs: Gmail, Office 365, Outlook, Custom SMTP, and more Vendorsmub Affected before 1.3.9.1 Fixed in 1.3.9.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wp-ecommerce:easy_wp_smtp:*:*:*:*:*:wordpress:*:* | up to 1.3.9 | Vulnerable | WPecommerce, Alexanderfoxc |
- cpe:2.3:a:wp-ecommerce:easy_wp_smtp:*:*:*:*:*:wordpress:*:* Versions up to 1.3.9 Vulnerable ·WPecommerce, Alexanderfoxc
Remediation
- Fix · CNA Easy WP SMTP – WordPress SMTP and Email Logs: Gmail, Office 365, Outlook, Custom SMTP, and more (smub) Fixed in 1.3.9.1
Timeline
- 2026-10-02 Threatist record created from CVE-2019-25141
- 2026-10-03 Alias added: GHSA-rpx2-wvxr-qvrr
References
Exploit 2
More smub vulnerabilities
- TI-2026-07755 WPCode <= 2.3.5 - Authenticated (Author+) Remote Code Execution via CPT Capability Bypass via XML-RPC wp.newPost CVSS 3.1HIGH 8.8
- TI-2026-83530 Remote code execution in NextGEN Gallery plugin for WordPress CVSS 3.1HIGH 8.8
- TI-2026-78567 PHP object injection in Duplicator and Duplicator Pro plugins CVSS 3.1HIGH 8.8
- TI-2026-01649 ExactMetrics 8.6.0 - 9.0.2 - Authenticated (Custom) Insecure Direct Object Reference to Arbitrary Plugin Installation CVSS 3.1HIGH 8.8
- TI-2026-01160 Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery <= 4.0.4 - Authenticated (Author+) Local File Inclusion CVSS 3.1HIGH 8.8
- TI-2025-12465 Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery <= 3.59.12 - Authenticated… CVSS 3.1HIGH 8.8
Sources
- CVE-2019-25141 · CVE Program
- CVE-2019-25141 · NVD
- FIRST EPSS
- GHSA-rpx2-wvxr-qvrr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences