Mesmerize <= 1.6.89 & Materialis <= 1.0.172 - Authenticated Arbitrary Options Update
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Mesmerize & Materialis themes for WordPress are vulnerable to authenticated options change in versions up to, and including,1.6.89 (Mesmerize) and 1.0.172 (Materialis). This is due to 'companion_disable_popup' function only checking the nonce while sending user input to the 'update_option' function. This makes it possible for authenticated attackers to change otherwise restricted options.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| extendthemes | Materialis | up to 1.0.172 | — | No fix listed | CNA |
| extendthemes | Mesmerize | up to 1.6.89 | — | No fix listed | CNA |
- Materialis Vendorextendthemes Affected up to 1.0.172 Fixed in — No fix listed CNA
- Mesmerize Vendorextendthemes Affected up to 1.6.89 Fixed in — No fix listed CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:extendthemes:materialis:*:*:*:*:*:wordpress:*:* | before 1.0.173 | Vulnerable | extendthemes |
| cpe:2.3:a:extendthemes:mesmerize:*:*:*:*:*:wordpress:*:* | before 1.6.90 | Vulnerable | extendthemes |
- cpe:2.3:a:extendthemes:materialis:*:*:*:*:*:wordpress:*:* Versions before 1.0.173 Vulnerable ·extendthemes
- cpe:2.3:a:extendthemes:mesmerize:*:*:*:*:*:wordpress:*:* Versions before 1.6.90 Vulnerable ·extendthemes
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2019-25142
- 2026-10-03 Alias added: GHSA-w4h9-w7jf-x53v
References
Patch 3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8c9c3302-47cd-4dbe-b79e-5e6032928074?source=cve
- https://themes.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=121291%40mesmerize&new=121291%40mesmerize&sfp_email=&sfph_mail=
- https://themes.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=121290%40materialis&new=121290%40materialis&sfp_email=&sfph_mail=
More extendthemes Materialis vulnerabilities
- TI-2023-03001 Materialis <= 1.1.24 - Missing Authorization to Limited Arbitrary Options Update CVSS 3.1MEDIUM 6.5
Sources
- CVE-2019-25142 · CVE Program
- CVE-2019-25142 · NVD
- FIRST EPSS
- GHSA-w4h9-w7jf-x53v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences