Contact Form & SMTP Plugin by PirateForms <= 2.5.1 - Unauthenticated HTML injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Contact Form & SMTP Plugin by PirateForms plugin for WordPress is vulnerable to HTML injection in the ‘public/class-pirateforms-public.php’ file in versions up to, and including, 2.5.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary HTML in emails that could be used to phish unsuspecting victims.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Contact Form & SMTP Plugin for WordPress by PirateForms (smub) Fixed in 2.5.2
Timeline
- 2026-10-02 Threatist record created from CVE-2019-25145
- 2026-10-03 Alias added: GHSA-mcgq-qxvq-33gm
- 2026-10-11 EPSS moved to the 50th–90th percentile
References
More smub vulnerabilities
- TI-2026-07755 WPCode <= 2.3.5 - Authenticated (Author+) Remote Code Execution via CPT Capability Bypass via XML-RPC wp.newPost CVSS 3.1HIGH 8.8
- TI-2026-83530 Remote code execution in NextGEN Gallery plugin for WordPress CVSS 3.1HIGH 8.8
- TI-2026-78567 PHP object injection in Duplicator and Duplicator Pro plugins CVSS 3.1HIGH 8.8
- TI-2026-01649 ExactMetrics 8.6.0 - 9.0.2 - Authenticated (Custom) Insecure Direct Object Reference to Arbitrary Plugin Installation CVSS 3.1HIGH 8.8
- TI-2026-01160 Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery <= 4.0.4 - Authenticated (Author+) Local File Inclusion CVSS 3.1HIGH 8.8
- TI-2025-12465 Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery <= 3.59.12 - Authenticated… CVSS 3.1HIGH 8.8
Sources
- CVE-2019-25145 · CVE Program
- CVE-2019-25145 · NVD
- FIRST EPSS
- GHSA-mcgq-qxvq-33gm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences