Pretty Links <= 2.1.9 - Unauthenticated Stored Cross-Site Scripting via track_link
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Pretty Links plugin for WordPress is vulnerable to Stored Cross-Site Scripting via various IP headers as well as the referer header in versions up to, and including, 2.1.9 due to insufficient input sanitization and output escaping in the track_link function. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| supercleanse | PrettyLinks – Affiliate Links, Link Branding, Link Tracking, Marketing and Stripe Payments Plugin | before 2.1.10 | 2.1.10 | Patch available | CNA |
- PrettyLinks – Affiliate Links, Link Branding, Link Tracking, Marketing and Stripe Payments Plugin Vendorsupercleanse Affected before 2.1.10 Fixed in 2.1.10 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:prettylinks:pretty_links:*:*:*:*:*:wordpress:*:* | before 2.1.10 | Vulnerable | Pretty Links |
- cpe:2.3:a:prettylinks:pretty_links:*:*:*:*:*:wordpress:*:* Versions before 2.1.10 Vulnerable ·Pretty Links
Remediation
- Fix · CNA PrettyLinks – Affiliate Links, Link Branding, Link Tracking, Marketing and Stripe Payments Plugin (supercleanse) Fixed in 2.1.10
Timeline
- 2026-10-02 Threatist record created from CVE-2019-25147
- 2026-10-03 Alias added: GHSA-4r26-5226-443f
References
More supercleanse vulnerabilities
- TI-2026-83498 Stored cross-site scripting in ThirstyAffiliates plugin for WordPress CVSS 3.1HIGH 7.2
- TI-2026-10665 Members <= 3.2.22 - Unauthenticated Sensitive Information Disclosure via REST API Pagination Side Channel CVSS 3.1MEDIUM 5.3
- TI-2024-10199 Members <= 3.2.10 - Unauthenticated Content Restriction Bypass to Sensitive Information Exposure CVSS 3.1MEDIUM 5.3
- TI-2026-01011 Buy Now Plus <= 1.0.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes CVSS 3.1MEDIUM 6.4
- TI-2026-04417 PrettyLinks <= 3.6.20 - Authenticated (Administrator+) SQL Injection via 's' Parameter CVSS 3.1MEDIUM 4.9
Sources
- CVE-2019-25147 · CVE Program
- CVE-2019-25147 · NVD
- FIRST EPSS
- GHSA-4r26-5226-443f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences