Read the docs
TI-2019-15260 Aliases CVE-2019-25158GHSA-jx6q-fq9h-6g7q

pedroetb tts-api app.js onSpeechDone os command injection

Priority MEDIUM 46CWE-78Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.

Summary

A vulnerability has been found in pedroetb tts-api up to 2.1.4 and classified as critical. This vulnerability affects the function onSpeechDone of the file app.js. The manipulation leads to os command injection. Upgrading to version 2.2.0 is able to address this issue. The patch is identified as 29d9c25415911ea2f8b6de247cb5c4607d13d434. It is recommended to upgrade the affected component. VDB-248278 is the identifier assigned to this vulnerability.

Why it matters now

EPSS 0.02115 81st percentileScored 2026-11-07
Fix Fixed tts-api (npm): 2.2.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
pedroetbtts-api2.1.0; 2.1.1; 2.1.2; 2.1.3; 2.1.4—No fix listedCNA
—tts-api (npm)before 2.2.02.2.0Patch availableGHSA-jx6q-fq9h-6g7q
  • tts-api Vendorpedroetb Affected 2.1.0; 2.1.1; 2.1.2; 2.1.3; 2.1.4 Fixed in — No fix listed CNA
  • tts-api (npm) Vendor— Affected before 2.2.0 Fixed in 2.2.0 Patch available GHSA-jx6q-fq9h-6g7q

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pedroetb:tts-api:*:*:*:*:*:*:*:*before 2.2.0Vulnerablepedroetb
  • cpe:2.3:a:pedroetb:tts-api:*:*:*:*:*:*:*:* Versions before 2.2.0 Vulnerable ·pedroetb

Remediation

  • Fix · GHSA-jx6q-fq9h-6g7q tts-api (npm) Fixed in 2.2.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-25158
  2. 2026-10-03 Alias added: GHSA-jx6q-fq9h-6g7q

References

Sources