Advanced Access Manager <= 5.9.8.1 - Unauthenticated Arbitrary File Read
Priority MEDIUM 54CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The Advanced Access Manager plugin for WordPress is vulnerable to Unauthenticated Arbitrary File Read in versions up to, and including, 5.9.8.1 due to insufficient validation on the aam-media parameter. This allows unauthenticated attackers to read any file on the server, including sensitive files such as wp-config.php
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02772 86th percentileScored 2026-11-07
Fix Fixed Advanced Access Manager – Access Governance for WordPress (vasyltech): 5.9.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Advanced Access Manager – Access Governance for WordPress (vasyltech) Fixed in 5.9.9
Timeline
- 2026-10-02 Threatist record created from CVE-2019-25213
- 2026-10-03 Alias added: GHSA-wx98-rpcr-jrwv
References
More AAM Advanced Access Manager vulnerabilities
- TI-2020-18378 The Advanced Access Manager plugin before 6.6.2 for WordPress allows privilege escalation… CVSS 3.1HIGH 8.8
- TI-2014-05002 WordPress Advanced Access Manager Plugin before 2.8.2 has an Arbitrary File Overwrite Vulnerability CVSS 3.1HIGH 7.2
- TI-2024-19301 WordPress Advanced Access Manager plugin <= 6.9.20 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2023-28321 WordPress Advanced Access Manager Plugin <= 6.9.18 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2023-27785 WordPress Advanced Access Manager Plugin <= 6.9.15 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2023-28322 WordPress Advanced Access Manager Plugin <= 6.9.18 is vulnerable to Open Redirection CVSS 3.1MEDIUM 5.4
Sources
- CVE-2019-25213 · CVE Program
- CVE-2019-25213 · NVD
- FIRST EPSS
- GHSA-wx98-rpcr-jrwv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences