WP Cost Estimation < 9.660 - Upload Directory Traversal
Priority LOW 36CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The WP Cost Estimation plugin for WordPress is vulnerable to Upload Directory Traversal in versions before 9.660 via the uploadFormFiles function. This allows attackers to overwrite any file with a whitelisted type on an affected site.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00614 49th percentileScored 2026-11-07
Fix Fixed WP Cost Estimation & Payment Forms Builder (loopus): 9.660
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA WP Cost Estimation & Payment Forms Builder (loopus) Fixed in 9.660
Timeline
- 2026-10-02 Threatist record created from CVE-2019-25295
- 2026-10-03 Alias added: GHSA-4446-h7rg-g9q3
References
More loopus vulnerabilities
- TI-2019-15350 WP Cost Estimation <= 9.642 - Missing Authorization to Arbitrary File Upload/Delete CVSS 3.1CRITICAL 9.8
- TI-2026-22456 WordPress WP Attractive Donations System - Easy Stripe & Paypal donations plugin <= 1.25 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.3
- TI-2026-19636 WordPress WP Cost Estimation & Payment Forms Builder plugin < 10.3.0 - Broken Access Control vulnerability CVSS 3.1HIGH 7.5
- TI-2025-16597 Missing authorization in loopus WP Attractive Donations System - Easy Stripe & Paypal… CVSS 3.1HIGH 7.5
- TI-2024-20213 WordPress WP Cost Estimation & Payment Forms Builder plugin <= 10.1.75 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
- TI-2026-08129 Cross-site scripting in loopus WP Cost Estimation & Payment Forms Builder CVSS 3.1HIGH 7.2
Sources
- CVE-2019-25295 · CVE Program
- CVE-2019-25295 · NVD
- FIRST EPSS
- GHSA-4446-h7rg-g9q3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences