Resource allocation without limits in Kubernetes
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 fixed, 6 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-770.
Summary
In all Kubernetes versions prior to v1.11.8, v1.12.6, and v1.13.4, users that are authorized to make patch requests to the Kubernetes API Server can send a specially crafted patch of type "json-patch" (e.g. `kubectl patch --type json` or `"Content-Type: application/json-patch+json"`) that consumes excessive resources while processing, causing a Denial of Service on the API Server.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Kubernetes | Kubernetes | v1.0.x; v1.1.x; v1.2.x; v1.3.x; v1.4.x; v1.5.x; v1.6.x; v1.7.x; v1.8.x; v1.9.x; v1.10.x; before v1.11.8; before v1.12.6; before v1.13.4 | v1.11.8, v1.12.6, v1.13.4 | Patch available | CNA |
| — | k8s.io/kubernetes (Go) | 1.0.0 – 1.10.14 | — | No fix listed | GHSA-q4rr-64r9-fwgf |
| — | k8s.io/kubernetes (Go) | 1.11.0 to before 1.11.8 | 1.11.8 | Patch available | GHSA-q4rr-64r9-fwgf |
| — | k8s.io/kubernetes (Go) | 1.12.0 to before 1.12.6 | 1.12.6 | Patch available | GHSA-q4rr-64r9-fwgf |
| — | k8s.io/kubernetes (Go) | 1.13.0 to before 1.13.4 | 1.13.4 | Patch available | GHSA-q4rr-64r9-fwgf |
- Kubernetes VendorKubernetes Affected v1.0.x; v1.1.x; v1.2.x; v1.3.x; v1.4.x; v1.5.x; v1.6.x; v1.7.x; v1.8.x; v1.9.x; v1.10.x; before v1.11.8; before v1.12.6; before v1.13.4 Fixed in v1.11.8, v1.12.6, v1.13.4 Patch available CNA
- k8s.io/kubernetes (Go) Vendor— Affected 1.0.0 – 1.10.14 Fixed in — No fix listed GHSA-q4rr-64r9-fwgf
- k8s.io/kubernetes (Go) Vendor— Affected 1.11.0 to before 1.11.8 Fixed in 1.11.8 Patch available GHSA-q4rr-64r9-fwgf
- k8s.io/kubernetes (Go) Vendor— Affected 1.12.0 to before 1.12.6 Fixed in 1.12.6 Patch available GHSA-q4rr-64r9-fwgf
- k8s.io/kubernetes (Go) Vendor— Affected 1.13.0 to before 1.13.4 Fixed in 1.13.4 Patch available GHSA-q4rr-64r9-fwgf
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kubernetes:kubernetes:*:*:*:*:*:*:*:* | before 1.11.8; 1.12.0 to before 1.12.6; 1.13.0 to before 1.13.4 | Vulnerable | Kubernetes |
| cpe:2.3:a:redhat:openshift_container_platform:3.10:*:*:*:*:*:*:* | 3.10 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* | 3.11 | Vulnerable | Red Hat |
- cpe:2.3:a:kubernetes:kubernetes:*:*:*:*:*:*:*:* Versions before 1.11.8; 1.12.0 to before 1.12.6; 1.13.0 to before 1.13.4 Vulnerable ·Kubernetes
- cpe:2.3:a:redhat:openshift_container_platform:3.10:*:*:*:*:*:*:* Versions 3.10 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* Versions 3.11 Vulnerable ·Red Hat
Remediation
- Fix · CNA Kubernetes (Kubernetes) Fixed in v1.11.8, v1.12.6, v1.13.4
- Fix · GHSA-q4rr-64r9-fwgf k8s.io/kubernetes (Go) Fixed in 1.11.8 Advisory →
- Fix · GHSA-q4rr-64r9-fwgf k8s.io/kubernetes (Go) Fixed in 1.12.6 Advisory →
- Fix · GHSA-q4rr-64r9-fwgf k8s.io/kubernetes (Go) Fixed in 1.13.4 Advisory →
Red Hat 2 advisories
- RHSA-2019:3239 Released 2019-10-29 · Red Hat rating ImportantOpenShift Container Platform 3.10 atomic-openshift security update
- Red Hat OpenShift Container Platform 3.10 atomic-openshift-3.10.181-1.git.0.3ab4b3d.el7, atomic-openshift-clients-3.10.181-1.git.0.3ab4b3d.el7, atomic-openshift-clients-redistributable-3.10.181-1.git.0.3ab4b3d.el7 +10
- RHSA-2019:1851 Released 2019-07-24 · Red Hat rating ModerateOpenShift Container Platform 3.11 security update
- Red Hat OpenShift Container Platform 3.11 atomic-openshift-3.11.129-1.git.0.bd4f2d5.el7, atomic-openshift-clients-3.11.129-1.git.0.bd4f2d5.el7, atomic-openshift-clients-redistributable-3.11.129-1.git.0.bd4f2d5.el7 +11
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.4 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.5 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.6 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.7 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.9 | Affected | No fix yet: Fix deferred |
| Red Hat Storage 3 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.10 | Fixed | RHSA-2019:3239 |
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2019:1851 |
Not affected: 1 product
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1002100
- 2026-10-03 Alias added: GHSA-q4rr-64r9-fwgf
References
Advisory 5
Other 5
- https://groups.google.com/forum/#%21topic/kubernetes-announce/vmUUNkYfG9g
- https://github.com/kubernetes/kubernetes
- https://groups.google.com/forum/#!topic/kubernetes-announce/vmUUNkYfG9g
- https://security.netapp.com/advisory/ntap-20190416-0002
- https://web.archive.org/web/20210125011246/https://www.securityfocus.com/bid/107290
More Kubernetes vulnerabilities
- TI-2018-16130 Improper privilege management in Kubernetes CVSS 3.0CRITICAL 9.8
- TI-2019-08418 Kubernetes kubelet exposes /debug/pprof info on healthz port CVSS 3.1HIGH 8.2
- TI-2023-05086 Kubernetes - Windows nodes - Insufficient input sanitization in in-tree storage plugin leads to privilege escalation CVSS 3.1HIGH 8.8
- TI-2023-03433 Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation CVSS 3.1HIGH 8.8
- TI-2023-02285 Bypass of seccomp profile enforcement CVSS 3.1MEDIUM 5.5
- TI-2017-14755 Link following in Kubernetes CVSS 3.0CRITICAL 9.6
Sources
- CVE-2019-1002100 · CVE Program
- CVE-2019-1002100 · NVD
- FIRST EPSS
- GHSA-q4rr-64r9-fwgf · GitHub Advisory Database · CC BY 4.0
- CVE-2019-1002100 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences