Read the docs

Missing authorization in Jenkins Cloud Foundry Plugin

Priority MEDIUM 41CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

A exposure of sensitive information vulnerability exists in Jenkins Cloud Foundry Plugin 2.3.1 and earlier in AbstractCloudFoundryPushDescriptor.java that allows attackers with Overall/Read access to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Why it matters now

EPSS 0.01359 71st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:cloudfoundry (Maven): 2.3.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Cloud Foundry Pluginup to 2.3.1—No fix listedCNA
—org.jenkins-ci.plugins:cloudfoundry (Maven)before 2.3.22.3.2Patch availableGHSA-2mh9-wpgv-7xr8
  • Jenkins Cloud Foundry Plugin VendorJenkins Affected up to 2.3.1 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:cloudfoundry (Maven) Vendor— Affected before 2.3.2 Fixed in 2.3.2 Patch available GHSA-2mh9-wpgv-7xr8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:cloud_foundry:*:*:*:*:*:jenkins:*:*up to 2.3.1VulnerableJenkins
  • cpe:2.3:a:jenkins:cloud_foundry:*:*:*:*:*:jenkins:*:* Versions up to 2.3.1 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-2mh9-wpgv-7xr8 org.jenkins-ci.plugins:cloudfoundry (Maven) Fixed in 2.3.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1003025
  2. 2026-10-03 Alias added: GHSA-2mh9-wpgv-7xr8

References

Sources