Read the docs

Insufficiently protected credentials in Jenkins Repository Connector Plugin

Priority LOW 34CWE-522Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.

Summary

An insufficiently protected credentials vulnerability exists in Jenkins Repository Connector Plugin 1.2.4 and earlier in src/main/java/org/jvnet/hudson/plugins/repositoryconnector/ArtifactDeployer.java, src/main/java/org/jvnet/hudson/plugins/repositoryconnector/Repository.java, src/main/java/org/jvnet/hudson/plugins/repositoryconnector/UserPwd.java that allows an attacker with local file system access or control of a Jenkins administrator's web browser (e.g. malicious extension) to retrieve the password stored in the plugin configuration.

Why it matters now

EPSS 0.00393 33rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:repository-connector (Maven): 1.2.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Repository Connector Pluginup to 1.2.4—No fix listedCNA
—org.jenkins-ci.plugins:repository-connector (Maven)before 1.2.51.2.5Patch availableGHSA-99jc-v8pq-6qm4
  • Jenkins Repository Connector Plugin VendorJenkins Affected up to 1.2.4 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:repository-connector (Maven) Vendor— Affected before 1.2.5 Fixed in 1.2.5 Patch available GHSA-99jc-v8pq-6qm4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:repository_connector:*:*:*:*:*:jenkins:*:*up to 1.2.4VulnerableJenkins
  • cpe:2.3:a:jenkins:repository_connector:*:*:*:*:*:jenkins:*:* Versions up to 1.2.4 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-99jc-v8pq-6qm4 org.jenkins-ci.plugins:repository-connector (Maven) Fixed in 1.2.5 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1003038
  2. 2026-10-03 Alias added: GHSA-99jc-v8pq-6qm4

References

  • TI-2021-04698 Cross-site scripting in Jenkins Repository Connector Plugin CVSS 3.1MEDIUM 5.4
  • TI-2022-15110 Cross-site scripting in Jenkins Repository Connector Plugin CVSS 3.1MEDIUM 5.4
  • TI-2020-02026 Cleartext transmission of sensitive information in Jenkins Repository Connector Plugin CVSS 3.1MEDIUM 5.3
  • TI-2022-17119 Missing authorization in Jenkins Repository Connector Plugin CVSS 3.1MEDIUM 4.3
  • TI-2022-17118 Missing authorization in Jenkins Repository Connector Plugin CVSS 3.1MEDIUM 4.3

Sources