Read the docs

Insufficiently protected credentials in JenkinsAppDynamics Dashboard Plugin

Priority MEDIUM 41CWE-522Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.

Summary

An insufficiently protected credentials vulnerability exists in JenkinsAppDynamics Dashboard Plugin 1.0.14 and earlier in src/main/java/nl/codecentric/jenkins/appd/AppDynamicsResultsPublisher.java that allows attackers without permission to obtain passwords configured in jobs to obtain them.

Why it matters now

EPSS 0.01418 72nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:appdynamics-dashboard (Maven): 1.0.15

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkinsAppDynamics Dashboard Pluginup to 1.0.14—No fix listedCNA
—org.jenkins-ci.plugins:appdynamics-dashboard (Maven)before 1.0.151.0.15Patch availableGHSA-mmqx-g78c-hvfj
  • JenkinsAppDynamics Dashboard Plugin VendorJenkins Affected up to 1.0.14 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:appdynamics-dashboard (Maven) Vendor— Affected before 1.0.15 Fixed in 1.0.15 Patch available GHSA-mmqx-g78c-hvfj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:appdynamics:*:*:*:*:*:jenkins:*:*up to 1.0.14VulnerableJenkins
  • cpe:2.3:a:jenkins:appdynamics:*:*:*:*:*:jenkins:*:* Versions up to 1.0.14 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-mmqx-g78c-hvfj org.jenkins-ci.plugins:appdynamics-dashboard (Maven) Fixed in 1.0.15 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1003039
  2. 2026-10-03 Alias added: GHSA-mmqx-g78c-hvfj

References

Sources